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SQL Server Training

Objectives: e Real-Time Working eInterview Suitable ¢70% Exam Coverage

[% Trainer: Mr. Sreedhar [8+ years of IT Exp, 5+ in SQL]

@ Duration: 35-40 hours, Daily 1 hour

Modes: Normal / Fast Track / One on One

O Fee: (Normal track) 5000/-

Available Batches: 8 AM, 9 AM, 10 AM, 11 AM, 5 PM, 6PM

Institute Provides

e In-Depth Theory & practical Material e Daily Live Class Videos Shared
e Complete Practical Oriented Training e Good Interaction with the Trainers
e Mock Interviews e Resume Preparation Sessions

SQL SERVER SCENARIOS

|
SQL Databases

[Cloud & On-premises] T Hr Case Study 1:

Sub Queries, Set Theory, & Joins based

SQL Server Introduction 2 Hrs
SQL & T-SQL elements | 2 Hrs
DDL, DML, DCL, TCL, DRL | 8 Hrs
Joins, Sub Queries & Set | 5 Hrs

Case Study 2:
Views, Procedures, & Functions based

Views, Procedures, & Fun |4 Hrs Case Study 3:
Cursors & Triggers | 3 Hrs CTE, Temporary Tables, &Variables based
Temporary Tables |2 Hrs

Temporary Variables | 2 Hrs SOL SERVER PROJECTS

Dynamic SQL & Exceptions |2 Hrs

A) BANKING PROJECT

| with different tables, views, procedure,
RESUME PREP & FAQS | 2 Hrs functions, and queries

Miscellaneous 2 Hrs

Real-time and Real-world examples tailored for better learning
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MANDATORY Topic 1: DATA, DATABASE AND DATAWAREHOUSE FUNDAMENTALS

Data and Database Fundamentals

>Data and Data Availability in IT

>Database, Data Warehouse, and RDBMS

»>Data storage areas [structured, semi and .
X

OLTP ~

unstructured

>RDBMS real-time projects and areas Cubes
>Components of RDBMS
»Normalized and de-normalized
databases ‘i:::;ﬂr'
[BI and non-BI] Files Data
Warehouse

i >SQL Versus T-SQL [MS SQL]
! >Other popular database in IT [ORACLE
i and TERADATA] and differences

>SQL Server Job Market and
Opportunities

Data warehouse Fundamentals
»Data warehouse, Data Mart & differences

. Kimball Model Inmon Model
>Types of data marts & real-time usage

>ODS, Stage, EDW, and DW definitions = -8 B~
»>Data Lake and Blob Storages a= £ [ Bl [ - e

>DWH Life Cycles P ]
>DWH Approaches (INMON and KIMBALL)
>Data Granularity, Data movement stages

-

MANDATORY Topic 2: DATA MODEL FUNDAMENTALS [E-R MODEL AND DIMENSIONAL MODEL]

[Theory and Complete Practical]

>Dimension, Dimension Table & types

>Fact, Fact Table & measures types

H \
| I
0 I
I I
] I
I I
0 I
| :
i >Fact less fact table [ time E
| >Schemas (Star, Snow Flake, Galaxy & Hybrid) | timekey !
1 , . ay I
| >Surrogate key and usages m real tlme A B wask —— E
+ >Business, Conceptual, Logical, Physical g = |
i Data Models =1 | :
i >1:1, 1: Many, Many: Many relationships e R |
| »Active, Inactive relationships T ‘0“_“0"-'“-‘!' i i
' »Single and Bidirectional relationships ooy (S Sy !
| >Cross filtering relationship EI'“ S |

. . I
| >Role Playing real-time usage meres | [_avases | i
I I
: I
! I

>Surrogate key live usages with practical
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TOPIC 1: INSTALLATION [SQL Server Instance]

>Installing SQL Server Instance and multiple Instances
>Installing SQL Server usage client components

>Azure Data Studio understanding
>SQL Developer and Operations Studio

| >SSMS Installation E
I >SQL Server Service Starting |

e S o i i i e e e i

| >What is SQL? |
i >How many areas we can use SQL to communicate with Databases? |
i >SQL usage in OLTP, ETL, Reporting & Analysis Process ﬁ
i >Azure Data Studio understanding E
! >SQL Versus T-SQL E
i »Various Tools and Utilities to write SQL !

TOPIC 3: SQL Server Editions, Databases, and Tables

>Server name or Instance name & authentication E
>»Versions and Editions in SQL Server i
>Connections [Local and Remote] |
»>Editions of SQL Server :
Enterprise Edition |
Standard Edition t
Developer Edition |
Work Group Edition :
Express Edition |
>»SQL Server and SSMS Installation :
>SQL Server Management Studio |
Object Explorer :
Query Editor |
>System Databases and User Databases |
>System tables and User tables i

______________________________________________________________________________________________

______________________________________________________________________________________________

>System Defined Databases and usages E
>User defined databases and usages E
>Master, MSDB, TEMPDB and others real-time usage E
»>Database creation GUI and Code [MDF & LDF files] :
>SQL Server Agent usage |
>Windows Vs. SQL Server Authentication !
_ >System tables and User tables i

I
1
I
1
I
1
I
1
I
1
I
1
I
I
I
I
I
I
|
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TOPIC 5: COMMAND, QUERY, AND SQL SERVER ARCHITECTURE

> Differences between command and query

>Query and command execution in SQL Server
>Parser, Compiler, Syntaxer, Optimizer, and CLR
>Storage Engine [SQL Engine]

>Lock, File, Transaction Manager, and Buffer Manager
>Buffers and Threads

> Buffers and Threads

e e e e e e R e B B B e
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______________________________________________________________________________________________

i >SQL Server Data Definition Language [DDL] E
| >SQL Server Data Manipulation Language [DML] |
i >SQL Server Data Control Language [DCL] E
' >SQL Server Transaction Dictionary Language [TCL] |
i >SQL Server Data Retrieval Language [DRL] E

TOPIC 7: DDL [DATA DEFINITION LANGUAGE]

> Creating Table Definitions [CREATE]

>Modifying Table Definitions [ALTER]

>Removing Table Definitions [DROP AND TRUNCATE]
>»TRUNACTE and DROP performance differences
>SQL Server Data Types

>Create table from another table

______________________________________________________________________________________________

TOPIC 8: DML [DATA MANIPULATION LANGUAGE]

______________________________________________________________________________________________

i >Inserting data into table [SELECT, INSERT and SELECT]
i »Single Insert and Multiple Inserts

i >Modifying table data [UPDATE]

i >Removing table data [DELETE]

>BULK INSERT and BCP [Bulk Copy Program]

>»MERGE command operation and Incremental Load [SCD and CD(]
>SQL Server Data Types

>Insert table from another table

Providing privileges [GRANT]
Removing privileges [REVOKE AND DENY

______________________________________________________________________________________________

vV
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TOPIC 10: TCL [TRANSACTION CONTROL LANGUAGE]

»Saving work [COMMIT]

>Restore work [ROLLBACK] E
»Saving period of work [SAVEPOINT] E

______________________________________________________________________________________________

T T T rp——

>Working on SELECT statement |
>Working on WHERE, GROUP BY, HAVING, and ORDER BY :
>Column and Table Aliases usage E

TOPIC 12: DATA FILTERING CLAUSES

>=, 1=, <>, > <, <=, =< etc... comparison Operators E
>AND, OR, NOT Logical operators i
>+, -, * /,Mod, Exp etc...Mathematical Operators E
>Order By, Top, Where, From and Like I
»>Group by and Having |
>IN, NOT IN, BETWEEN and NOT BETWEEN E
>ISNULL and NOT ISNULL i

______________________________________________________________________________________________

————

e e e e e e e e e

>Simple Sub Query

>Correlated Sub Query

> Differences between simple and correlated
>Nested Sub Query

>Working on TOP, MAX, and MIN real time queries

M

TOPIC 14: MULTI TABLE OPERATIONS [ROW-WISE SET THEORY]

| >Set theory generic protocols

i >INTERSECT

. >»UNION

i >UNION ALL

i YEXCEPT

| >Working on incremental loading
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TOPIC 15: MULTI TABLE OPERATIONS [COLUMN WISE-JOINS]

- - -y

>JOINS real time usage

>CROSS JOIN and CROSS APPLY
>INNER JOIN [EQUI, NON EQUI]
>NATURAL JOIN

»SELF JOIN

>INNER Vs. OUTER JOIN

>LEFT OUTER JOIN

>RIGHT OUTER JOIN

>FULL OUTER JOIN

>»Working on ON and WHERE clauses
>MERGE JOIN

>LOOP JOIN

>HASH JOIN

»Unmatched data retrieval
>Incremental load in real time using Joins

-

T -

______________________________________________________________________________________________

i >CHECK, NOT NULL, AND DEFAULT - Domain Integrity

i >Primary Key usage and limitations

' >Unique Key usage and limitations

i >Referential Integrity and FORGINE KEY

E >Candidate key and Alternate key

i >Normal column and Identity column

| >Surrogate key and Identity column usage

i >CASCADING OPTIONS

E ON DELETE CASCADE, ON UPDATE CASCADE, ON DELETE SET NULL,
i ON UPDATE SET NULL, ON UPDATE SET NO ACTION(Default)

———— A e S A A S M S A S A S M S M S S A S e

______________________________________________________________________________________________

>Clustered Index Design and Structures }
>Nonclustered Index Design and Structures |
>Unique Index Design i
>Index with Included Columns E
>Column storage index :
>Full-Text Index population |
>Filtered Index Design :
> Covering Index Design E
>B-Tree and Online Indexes |
>Indexed views Vs. Materialized views |
> Fill Factor, TEMPDB, Pat_Index i

o i e e e o i i e i i o i o S W i e S e e e e et o) e e - i s s o e i S e P
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TOPIC 18: SCHEMAS, SYNONYMS, SYSTEM DEFINED VIEWS AND PROCEDURES

>»What is Schema? and real time advantages with practical.
>What is Synonym? and real time advantages with practica
>System Defined Procedures usage with examples
sp_help, sp_helpdb, sp_helptext, sp_rename, sp_recompile, sp_tables
»System Defined Views usage with examples
sys.tables sysjobactivity, sysssislog

B
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TOPIC 19: DISTINCT, GROUP BY, ROLLUP, AND CUBE

>Differences between GROUP BY and DISTINCT and performance impact
>»GROUP BY and HAVING usages to identify and eliminate duplicates
>ROLLUP and CUBE usages

>Generating FULL TOTALS and SUB TOTALS

>Comparing ROLLUP, CUBE and GROUP functions

7’
~

>Advantages of Views in SQL

»Tables Vs. Views

>Simple View (Updatable View)
>Complex View (Non-Updatable View)
>Materialized View and real time usage
>Encrypted views Vs. Cascading views
»>Limitations of Views

~ s

__________________.,_
- - - -

TOPIC 21: FUNCTIONS [ SYSTEM, USER DEFINED, AND ANALYTICAL]

______________________________________________________________________________________________

>»Date and Time Formats and Functions
»Scalar - Valued Functions
»Table - Valued Functions
>String Functions
SUBSTRING, REPLICATE, REPLACE
REVERSE, CHARINDEX
LEFT, RIGHT, LEN
DFFERENCE, SOUNDEX

STRING_SPLIT
>Mathematical Functions

ABS, ROUND, LOG
FLOOR, CEILING

SUM, AVG, MAX, MIN, COUNT
SQUARE ROOT, SQUARE

SIN, TAN, COS

_______________________________________...,
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»Date Functions
DATEADD, DATE DIFF, DATE PART
FLOOR, CEILING
GETUTCDATE, GETDATE, CURRENT_TIMESTAMP, SYSDATETIME
DATE NAME, ISDATE
WEEKDAY, MONTHNAME, WEEKDAYNAME
SECOND, MINUTE, HOUR, ISDATE

> Other Generic Functions
COALESCE, NULL IF, CURRENT USER, IIF
ISNULL, NULLIF, SESSION_USER
SESSIONPROPERT, SYSTEM_USER, USER_NAME
FORMAT, INSTR, CONCAT

> Cast and Convert Functions
>IF, ELSE, CASE, WHEN & END
>PIVOT & UNPIVOT

>ANALYTICAL FUNCTIONS
ROW_NUMBER () and real time examples
RANK () and real time examples
DENSE RANK () and OVER () usages
NTILE advantage
PARTITION BY advantage
Using Group BY along with
Analytical Partition

>User Defined Functions Create
»User Defined Functions Calling

»Differences between Function &Procedure
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»>Use in Real Time and Types

>System Defined and User Defined Procedures
>Dynamic SQL Queries in Procedures

>IN, OUT, INOUT Parameters

>Compare Procedures and Functions
>READONLY Parameters

>Dynamic Data Insertions with Procedures
>Table Variables, Cloning & Data Inserts
>Using TEMP tables in procedures

»Stored Procedure inside Stored Procedure
>Optimizing tips for procedure
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TOPIC 23: DIFFERENT TYPES OF TABLES, VARIABLES, AND CTE

>Local variables vs Global variables with examples
>Local variables Vs. Temp variables and real time usage
>TEMPORARY table usages in real time

>Inline View Vs. Normal View

>CTE: Common Table Expressions

>CTE usage in real time

>Multiple examples using CTE

»ROW_NUMBER () with CTE Queries

>Recursive CTE

1
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TOPIC 24: TRIGGERS

- - -

>Use in Real Time and Types
>»SCHEMA BINDING
>Triggers Vs. Procedures
>Types of triggers
DML TRIGGERS, DDL TRIGGERS,FOR TRIGGERS, INSTEAD OF TRIGGERS
Rel-time usage of triggers at events

______________________________________________________________________________________________

| S S ———

’

TOPIC 25: CURSORS [USER DEFINED]

______________________________________________________________________________________________

>»What is cursor and advantages of it.

>Cursor Vs. Stored Procedure

>Working on different types of cursors

> Types of triggers
Static Cursors, Dynamic Cursors, Global Cursors, Local Cursors,
Forward only Cursors, Scroll Cursors, Keyset Cursors

________________\
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TOPIC 26: TRANSACTIONS, CHECKPOINT, AND DTC

o

>What is Transaction? usage of it?

>What is DTC [Distributed Transaction Coordinator]
>What is Checkpoint? usage of it?

> Transactions Vs. Checkpoint

U g S g S S NS g S S S S S S S S g g S S S S S S S S S S O SO S S S S —————————

—

______________________________________________________________________________________________

>IF, IIF, CASE > WHILE, WHEN
>Error Handling in T-SQL >Try, Catch, Throw
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TOPIC 28: DYNAMIC SQL IMPLEMENTATION

- -

>Creating Dynamic SELECT statement

>Passing dynamic table names

>Create a procedure with dynamic table names and variables
>Normal SQL Vs. Dynamic SQL

e S e e e e e

___________..‘
-

TOPIC 29: FUNCTIONS [ User Defined]

_______________________________________________________________________________________________

>Functions Vs. Procedures >Functions returning normal variables
»Functions returning tables > Calling inline functions

’
~

TOPIC 30: PERFORMANCE TUNING AND OPTIMIZATION PROCESS
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>Examples of performance issues in real time

>DTA (DB Engine Tuning Advisor)

»Audit Long Running Queries using DMVs and DMFs

> Activity Monitor Tool and Query Statistics Reports
»Logical I/0, Physical I/0 and Database 170, Wait Time
>Partition Functions and Partition Schemes - Usage

>Index Management : Internal, External Fragmentation
»>Index Page Count and Index Condition Checks

> ONLINE and RESUME Options

»Fast, Detailed Scans and Stats NoRecompute usages
>Creating Workload Files and Trace Files

> DTA with Query Cache (Procedure Cache) & .SQL File Inputs advantage
> Full Text Search (FTS) Mechanism advantage

>Processor, Disk, Memory, Transactions, Database Counters
>Query Costs : 10, CPU Cost, SubTree Cost, Operator Cost
>Parameter Sniffing and OPTIMIZE Options

»Spooling Mechanism and Spool Types for Query LoadS

> Execution Plan Issues with Parameter Sniffing

»Query Blocking Scenarios and Lock Monitors
>Serializable, Snapshot, Repeatable Read Isolation /li>
>Deadlock Simulation and Deadlock Prevention usage

> Full Text (FT) Indexes: Query Tuning. Filter Daemon Host
>Histograms and Event Handling Options

>Working with SQL SERVER Profiler

>Using Perfmon Tool and AM Tool

>Implementing Compressions for Read Only Data
>Parameter Sniffing and OPTIMIZE Options

>Implementing environment areas in the real time [DEV, TEST, UAT, and PROD]
>Real time scenarios and many important tips
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Power Bl POWER BI
{ FIRST DEMO [E 8 DATA ANALYST/ ANALYTICS
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Follow us on Instagram / Facebook
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