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Data Analytics

e Power Bl ¢ Advanced Excel ¢SQL Server e¢Python

@ Sessions from Industry Experts

@ 90 hrs, Daily 1 hour

6 Daily Class Videos Shared

(4 Rs. 20,000 (Online / Offline)

Multiple Batches Available
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MODULE DURATION FEE WHA YOU'LL LEARN
Power Bl 30days @ W --mmm--- Reports, Dashboards, KPls, Modelling, DAX
Excel 20days | --meee-- Basics to Advanced, Excel Analytics
SQL Server 20days @ = -=e=m--e- Querying databases, Important SQL constructs
Python 20days | -----e-- Data handling, pandas, matplotlib, automation
TOTAL 90 days 220,000 ¥ Master Data Analytics ¥
Prescriptive
Predictive
- Diagnostic How can
H we make it
== Descriptive What happen?
= j will happen?
<T Why did
> it happen?
- What
E happened?
=
= =
o

DATA ANALYTICS TYPES
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Introduction to Excel

» A description of the interface
» The menu system
» The fundamentals of spreadsheets

Personalizing Excel

» Changing Excel’s Default Options Using AutoCorrect and Customizing It
» Customizing the Ribbon

» Using Functions — Sum, Average, Max, Min, Count....
» Absolute, Mixed, and Relative Referencing

Arithmetic Functions

» Sumlif, Sumlfs Countlf, Countifs Averagelf, Averagelfs

Text Functions

» Upper, Lower, Proper
» Left, Mid, Right

» Trim, Len, Exact

» Concatenate

» Find, Substitute

Proofing and Formatting

» Formatting Cells with Number formats, Font formats, Alignment, Borders, etc
» Basic conditional formatting

Protecting Excel- Excel Security

» File Level Protection
» Workbook, Worksheet Protection
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Printing Workbooks

» Setting Up Print Area

» Customizing Headers & Footers

» Designing the structure of a template
» Print Titles -Repeat Rows / Columns

Advance Paste Special Techniques

» Paste Formulas, Paste Formats
» Transpose Tables
» Paste Validations

Time and Date Functions

» Today, Now » Day, Month, Year
» Date, Date if, DateAdd » Month, Weekday

New in Excel 2013 / 2016 & 365

» New Charts — Tree map & Waterfall
» Combo Charts — Secondary Axis

» Sunburst, Box, and whisker Charts

» Using Power Map and Power View

» Adding Slicers Tool in Pivot & Tables
» Sparklines -Line, Column & Win/ Loss
» Forecast Sheet

» Smart Lookup and manage Store

» New Controls in Pivot Table — Field, Items, and Sets
» Using 3-D Map

» Auto complete a data range and list
» Various Time Lines in Pivot Table

» Quick Analysis Tool

Filtering and Sorting

» Filtering on Text, Numbers & Colors
» Sorting Options
» Advanced Filters on 15-20 different criteria(s)

Printing Workbooks

» Setting Up Print Area

» Print Titles -Repeat Rows / Columns
» Designing the structure of a template
» Customizing Headers & Footers
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What-If Analysis

» Goal Seek

» Data Tables (PMT Function)
» Solver Tool

» Scenario Analysis

Data Validation

» Number, Date & Time Validation

» Dynamic Dropdown List Creation using Data Validation -— Dependency List
» Custom validations based on a formula for a cell

» Text and List Validation

Logical Analysis

» If Function » Nested If
» Complex if and or functions » How to Fix Errors — iferror

Arrays Functions

» What are the Array Formulas, Use of the Array Formulas?
» Array with if, len, and mid functions formulas.

» Basic Examples of Arrays (Using ctri+shifttenter).

» Advanced Use of formulas with Array.

» Array with Lookup functions

» Vlookup / HLookup » Creating Simple Pivot Tables

» Vlookup with Helper Columns » Classic Pivot table

» Creating Smooth User Interface » Basic and Advanced Value Field Setting
» Index and Match » Calculated Field & Calculated Items

» Reverse Lookup using Choose Function » Grouping based on numbers and Dates

» Nested VLookup
» Worksheet linking using Indirect

Slicers and Charts

» Using SLICERS, Filter data with Slicers
» Various Charts i.e. Bar Charts / Pie Charts / Line Charts
» Manage Primary and Secondary Axis

Excel Dashboard

» Planning a Dashboard
» Adding Dynamic Contents to Dashboard
» Adding Tables and Charts to Dashboard
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MANDATORY TOPIC 1: POWER Bl DEMO & DATA WAREHOUSE FUNDAMENTALS
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) Standard Bl Proc
@ Power Bl Demo content e =
ouTe hn-m'l'lnmh m Load Hugnochesw “;:::. D:ldmks D«ﬂmmnlml Ma M;lmw

» Data, Data Availability types in IT

Custemans

34-—)% % %

FLES [ DATA WAREROUSE CUBES REFOATS,
DASHBOARD

Infarmatics Teradata Hyperion tognes
Dracle

Dotostoge Esshase B0 ouTeUT
Abinita [H HANA MicraStrotegy | (sipesc

» IT data storage areas [File stream, Database]
» Data warehouse, Bl definitions and layers

. . . lNP'JT
» Power Bl existence in IT, Product services (boas|

t:l

Stondard
Bl Tosls

» Power Bl Tools and Components 0n 7 RS Wit s =

» On-Premise vs. Cloud B imbive) 0 Smeben A J
» OLAP vs. OLTP vs. Insights and Analytics [ droes  Grwean PYR —
@ Data warehouse Fundamentals e Hrmon Model

» Data warehouse, Data mart and differences % .=

» Types of data marts and real-time usage i é ﬁ"" _Ms E

» DWH Life Cycles, DWH principles N = P B v - "

» DWH Approaches (INMON and KIMBALL) g ol E

» Data Granularity, Data movement stages

@ [Theory and detailed practical with real-scenarios]

MANDATORY TOPIC 2: DATA MODEL THEORY AND PRACTICAL
T T — To

» Data model, use of data model in Power Bl

» Business, Conceptual, Logical, Physical models

» Dimension, Dimension table & types
(Conformed, Roleplay, Degenerated, Junk, SCD)

» Measures & Types

(fully additive, semi additive, non additive)
» Fact table & Types

( Snapshot, Incremental, Factless fact)
» Schemas (Star, Snow Flake, Galaxy & Hybrid)
» Surrogate key and usages in real time
» 1:1, 1: Many, Many: Many relationships
» Active, Inactive relationships
» Single and Bi-directional, Cross filter
» Advanced properties of fields e
(sort order, date category, aggregators)
» Snow Flake schema exmaples

Master Dimension

Snowflake Schema

TOPIC 1: INSTALLATION [POWER Bl DESKTOP, GATEWAY, SERVER, REPORT BUILDER & DAX STUDIO]

» Power Bl Cloud / Report Server Desktop installation

» DAX Studio installation, Gateway Installation %ﬁ 1
» Report Server Installation

» Paginated Report Builder Installation

STUDIO Furwer 81 gt Buskdes
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TOPIC 2: WORKING WITH POWER Bl DESKTOP AND CONNECTING TO MULTIPLE DATA SOURCES

@ [Theory and Co.mpfete Pre';ct-lcaI] G aEDEe B B

» Desktop over view and building blocks of . e feo SR Rel O oo | et
PBI Desktop R —

» Connecting to various sources and B ks Vieskiatios:  »
retrieving data ) sower 8 s et s
1. Flat, CSV, JSON, Excel files [} Dstatows -
2. Databases (SQL Server & Oracle) 0 Cossiin B R E ke
3. Web O s 00 M 1 i et
4. Multiple files load at a time B i o ¥ I—,, QO H
5. Azure SQL database and DWH T g gé ; [Rj E
6. Analysis Services Models R we e =§ TJ 0 o
(Tabular & ulti-dimensional) D) ctuss s RED -
7. Python Script O sk quer

8. M-Retrieval

TOPIC 3: WORKING WITH DATABASES, CUBES, MODES & CHANGING MODES

» Working on data modes[very detailed] i
a)lmport b)Direct Query c)Connect Live d) Mixed mode e) Chanding modes A T N

» Differences between Load and Edit options. " R e

» Retrive date from related data bases and cube .’ .

TOPIC 4: WORKNG ON POWER Bl DESKTOP COMPONENTS

>

» Power Query, Power Pivot, Power View, Power Map [

@) 2 ()
Pivot View Map

Query

TOPIC 5: POWER VIEW MENU TAB OPTIONS-RIBBON OPTIONS & REAL-TIME

| ‘

File Home Insert Modeling View Optimize Help External tools & Share
[—? g Excel workbook (5} Enter data ) | By - ' Ll New visual [9] -.:;-'J |"_'|L:| 2
i € Onslaks catalng ~ (@) Datavorss = - BEEhbh~dE [] Teut bew sl e ! =

Get K Transfgem Refresh -~ = = i MNew  Quick Publish  Prep data |
dataw [P 5QL Server [B Racont sources ~ datav OoEe~DEBED P More visuals v measre moasure Al

@File Tab [All options-Detailed Practical] @ View Tab [All options -Detailed Practical]

a)New, Open, Save report » Report Phone Layout / Desktop View
b)Export Power Bl Template (PBIT), PDF Show Gridlines, Snap Objects to Grid
c)import Power Bl Template, Power Query, Locking Objects on the surface

View, Model, Visual files » Bookmarks creation, viewing, & using in
d)Options and Settings & About Dashboard Selection Pane

[Hiding and showing objects]

@ Home Tab [All options- Detailed Practicall] ' . ) )
» Slicer and Sync Slicers explanation with

a)External Data: practical Performance analyzer test run
Get Data, Recent Sources, Enter Data ), Scale to fit: Page view, Mobile: Mobile

b) Transform data & edit parameters layout, Page options

c) Publishing to cloud service » Show panes: Filters, Bookmarks, Selection,

d) Prop data Al (2025) Performance Analyzer, Sync slicers

e) Quick sources f) Sensitivity
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@ Insert Tab [All options - Detailed Practicall ®

» Visuals: New Page, New Visual, More Visuals

» Al Visuals: Key Influencers, Decomposition
Tree, Smart Narrative, Q & A

» Elements: Text box, Buttons, Shapes, Image

» Power Platform: Paginated Report,
Power Apps, Power Automate

» Sparklines: Add a Sparkline

@ Format Tab [All options-Detailed Practical]

a)Edit interactions for the visual for
cross highlighting, cross filtering, and
none options.

b) Bring forward, send backward etc..
visual option (Z-Order)

@ Data / Drill Tab [All options-Detailed Practicall

Sl
¢==I
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Modeling Tab [All options-Detailed Practical]

a)Relationships: Manage Relationsips

b) Create roles and implement row-level
security & dynamic row-level security

Page Refresh: Change detection

Parameters: New parameter

Security: Manage roles, View as

Calculations: New measure, Quick measure,

New column, New table

Q & A: Language, Lunguistic Schema

® HELP Tab [All options-Detailed Practicall

a) Guided learning, documentation,
training videos, blogs, communities,
Power Bl for developers, support and
consulting services

@ External tools tab

a) Drill down report creation

b) Drill one level down, multiple levels, &
data drill

c) Visual table, Data point table

TOPIC 6: POWER Bl DATASET PROPERTIES

DAX studio

@ Optimize tab (2024)

Refresh, Pause, Preset, Optimization

‘

» Create hierarchies and analyzing data

» Create Groups (List, Bin)

» Hide / Unhide columns usage in real-time

» Consider table as Date Table

» Expand and collapse columns

» Incremental refresh & manage aggregations

(7] /8! grp_bin count_DiscountValue ~ [J% Date Hierarchy
| I8! grp_bin size_Actual_Fee UM Year
CJME Quarter
IB grp-caurselD :E Ml:lnth
| {8 grp_list_Actual_Fee O Day

TOPIC 7: POWER QUERY PROPERTIES [ 8 types of properties and M-Language ]

@ Queries properties [All options —Detailed Practicall]

a) Practical on duplicates & references
b) Create groups to classify tables

c) Refreshing table data, Creating reusable functions

© Query Properties

a) Data transformations by adding, removing
& retaining columns, duplicates, error

b) Working on reusable functions

c) Merging & Joining multiple queries

Copy
Paste

Delete

Rename

Enable load

Include in report refresh

Duplicate

Reference
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= 43 Copy Entire Table Keep Range of Rows...
@ Column Pl‘opel’tles [0 \se First Row as Headers Keep Duplicates
Fd  Add Custom Column. Keep Emors
Data typesl‘ types Of transforms [ Add Column From Examples.. T Remove Top Rows..
2 mvoke Custom Function.. Remove Bottom Rows...
- Numeric, text, date tranforms sy s A A
Add Index Column Remove Duplicates
1 = hioose Colummns, Remove Errors
@ Filter properties s ong s
Keep Bottom Rows. Append Cueries.
- Numeric, text & date tranforms — E—
= Bmove Split Column
2 ! :emome Other Columns G':c’” ‘: EI:""'
@ Parameters properties uplicate Column
i i il
Working on Any, List & Query parameters BT oot i
. . . =1 Rename,.
Working on multiple & cascading parameters Change e - Move
ransform . rill Down
14 Replace Values.., :n: :s New Quary
@ Miscellaneous Transformations E—
Towercase Round
Transpose rows, reverse rows, Pivot & Unpivot UPPERCASE Absolute Value
Quality Transforms [profiling, quality, distribution] Capitalize Each Word Factorial
Trim Base-10 Logarithm
® Mash up (M) language Clean Natural Logarithm
. . Length Power
Syntax, protocols, variables & conventions Jso'il e i
. . quare ROO
Let, In, semicolon, and other functions - | Text Transforms

TOPIC 8: POWER Bl VIEWS, FILTERS, VISUALS AND VISUAL FORMATING OPTIONS

@ Types of views in PBl Desktop
a) Report b) Data c) Relationship d) DAX Query

Build visual
© Worki ith diff tl I of filt ==
or- mg.wu- ifferent level of filters s ) R
a) Visualization b) Page c) Report
@ Data Display Visuals i g z E E g
Card, Multi-row, Table, Matrix, New -card (2024) e S B
@ Simple KPI visuals QP Y~
KPI, Gauge, Bullet Chart B3 B8 R Py
i i E-008 QL
@ More categories visuals
. 22D -
Charts

Rounded charts : Pie, donut

Bar: Stacked, Clustered, 100% Stacked

Trend: Line, Area, Stacked Area, Ribbon, Mixed, Treemap,
Funnel, Scatter, Waterfall

Maps (Bubble, Filled, Shape, ARCGis, Azure map 2024)

Al Visuals: Key-influencer, De-composition, Smart Narrative, QA | Table view:

Others: Sparklines, Metric, Paginated Report, R, Python

(1] EReport\.vit.-‘;\.«.* -

&g i Relatlonshlp view

® Custom Visuals

a) Bullet Chart b) Chiclet Slicer c) Hierarchy Slicer ol DAX Query view
d) Gantt Chart e) Histogram Chart f) Dual KPI g) Scroller
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® Non field visuals
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a) Image b) Textbox c) Shapes d) Button actions v O Data
Actions: Bookmark, page navigation, back , QA, : dB Build
a : Filters| ~ Pane
URL, apply slicers & clear slicers
manager v @ Format

@ Visual Interactions —

a) Slicers: types, usages, sync slicer [ Bokmars B e s

b) Filers & types R Selection

c) Edit Interactions :

d) Parameters & What-if parameters [ Pefomanceanlze

TOPIC 9: POWER Bl CLOUD SERVICE (app.powerbi.com)

@ WEB PORTAL NAVIGATIONS
1) Navigation pane, Portal URL

DEI Goad aftermoon, VinayTech = -
2) App Launcher, Settings, Help & Support AT
3) Feedback, Account Information

e e

oo0ee

© WORKSPACES

» My workspace and properties

» User app workspaces and properties
» Workspace Settings and Roles

» Workspace Access

©@DASH BOARD TEMPLATE

» Create dashboards e

» Add the below tiles P —
Image, Textboc, Video, Streaming, -
Live page, Visual, Bookmark, Workbook,
Insight, Usage metrics

» Share and Subscribe dash board e e

» Refresh Dashboard e

» Manage Alerts

@ APP WORKSPACES (or) CONTENT PACK
» Create, modify, and delete appspace :
» Add content (show or hide) B e "
» Audience (organization or users) :
» Additional Settings (copy, build)

» Publish and Update app

» Browse App in Web, Desktop and Mobile
» END USER EXPERIENCE PROVIDED

@ Report Server (On-Premise) operations
» Report Server Desktop and
Report Server install and practice.
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TOPIC 10: DAX - The below are the DAX categories, a few important functions covered for 6-7 hours

@ DAX Language General Topics & Advanced

» Syntax and usage
» Naming conventions, parameters
» Operators, functions (15 categories)

@ FILTER FUNCTIONS

» Addmissingitems, Filter, Filters,Distinct,
Values, Countrows, All, Allexcept, Earlier,
Earliest, KeepFilters, Remove filters,

» Context transition (row, column, filter, multi-row) Calculate, Calculatetable, AllSelected,

» DAX Queries, DAX Studio and SSMS
» DAX FAQS, Optimization & Standards

@ DAX Functions [Very Detailed Practice]

» Good material provided for all the functions
a) Date b) Filter c) Math & Trig d) Statistical
e) Table Manipulated f) Informational
g) Relationship h) Logical i) Parent Child
j) Time Intelligence j) INFO Function
h) Windows Functions (2022 Dec)

i) NEW Functions (2024)
Statements: Evaluate, Define, Var, Order By

@ DATE FUNCTIONS

» Calendar, Calendarauto, Day, Month, Year
YearFrac, Date, Time, DateValue, TimeValue,
Edate, EOMonth, Weekday, WeekOfMonth
Today, UTCToday, Now, UTCNow, DateDiff

© TIME INTELLIGENCE FUNCTIONS

» DatesBetween, DatesInPeriod,
ClosingBalanceofmonth, Quarter, Year
OpeningBalanceOfMonth, Quater, Year
Datesytd, Datesqtd, Datesmtd, Totalqtd,
Totalmtd, Totalytd ,FirstDate, LastDate,
FirstNonBlankDate, Lastnonblankdate,
NextDay, NextMonth, NextYuarter, NextYear,
ParallelPeriod, SamePeriodLastYear,
PreviousDay, PreviousMonth, Quarter, Year
StartOfMonth, Quarter Year

®© LOGICAL FUNCTIONS
» And, Or, Not, Iferror, If, Switch, In,
True , False, Coalesce

© PARENT & CHILD FUNCTIONS

» Path, Pathlength, Pathcontains,
Pathreverse, Pathltem

® INFO FUNCTIONS
» INFO- View.Measures, View.Columns, View.Tables

@ WINDOWS FUNCTIONS (2022)
» Index, Offset, Partition, Window

AllINoBlankRow
©®@ RELATIONSHIP FUNCTIONS

» Related, Relatedtable, UseRelationship,
Crossfilter, ContainsStringExact

© INFORMATION FUNCTIONS

» ContainsRow, Contains, ContainsString,
Iseven, Isodd, Istext, UserName,
UserPricipalName, LookUpValue, IsError,
IsNonText, IsNumber, IsLogical, Isinscope,
Isonorafter,Hasonefilter, IsCrossFiltered

©® AGGREGATE FUNCTIONS

» Sum, Sumx, Average, AverageX, AverageA,
Max,MaxX,MaxA, Min, Minx,MinA,Count,
CountX, CountA, CountBlank, DistantCount,
DistantCountNoBlank, Product, ProductX,
Courtrows, Approximate, Distinctcount

©@ MATH AND TRIG FUNCTIONS

» Round, MRound, Roundup, Rounddown, Rand,
RandBetween, Sqgrt, Trunc, In, Ceiling, Floor,
Gced, Lcd, Exp, Fact, Even, Odd, ABS, Convert,
Currency, Sign

@ STATISTICAL FUNCTIONS

» Permut, Rank.eq, Rankx, Sampl,
Statistical data, Operation functions
MORE DA STATICAL FUNCTIONS COVERED

© TABLE MANIPULATION FUNCTIONS

» AddColumns, AddMissingltems, CrossJoin,
CurrentGroup, DataTable, DetailRows,
DistinctColumn, DistinctTable, Except,Filters,
Generate, GenerateSeries, Groupby,
DataTable, Except, Intersect, Union,
Symmarize, Summarizecolumn,
GenerateSeries, NaturallnnerJoin,
NaturalLeftOuterJoin, Crossjoin, Treatas,
Isempty, Row SelectColumns, Values,

@TEXTUAL FUNCTIONS

» Blank, Code,Unichar,Concatenate,
Combinevalues, Cacatinatex, Trim, Rept,
Replace, Substitute, Find, Search, Format,
Mid, Left, Right, Value, Upper, Lower

@ NEW FUNCTIONS (2024)
» First, Last, Previous, Next, Rank,
Rownumber, Lineast, Match
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MANDATORY Topic 1: DATA, DATABASE AND DATAWAREHOUSE FUNDAMENTAL

@ Data and Database Fundamentals

» Data, Data Availability types in IT

» Database, Data Warehouse, and RDBMS

» Data storage areas [structured, semi and unstructured

» RDBMS real-time projects and areas

» Components of RDBMS

» Normalized and de-normalized databases
[Bl and non-Bl]

» SQL Versus T-SQL [MS SQL]

» Other popular database in IT [ORACLE
and TERADATA] and differences

» SQL Server Job Market and Opportunities

» Power Bl History, releases and blogs

@ Data warehouse Fundamentals

» Data warehouse, Data Mart and differences
» Types of data marts and real-time usage

» ODS, Stage, EDW, and DW definitions

» Data Lake and Blob Storages

» DWH Life Cycles

» Data Granularity, Data movement stages

TOPIC 1: INSTALLATION ISAL Server Instance, Editions, Databases, and Tablesl

» Installing SQL Server Instance and multiple Instances

» SSMS Installation, Azure Data Studio, SQL Developer and Operations Studio

» SQL Server Service Starting

» Server name or Instance name & authentication

» Versions and Editions in SQL Server

» Connections [Local and Remote]

» Editions of SQL Server - Enterprise Edition, Standard Edition, Developer Edition,
Work Group Edition, Express Edition

TOPIC 2: DRTABASES AND TABLES

» System Defined Databases & usages - Master, MSDB, TEMPDB and others real-time usage
» User defined databases and usages

» Database creation GUl and Code [MDF & LDF files]

» Differences between command and query

» Query and command execution in SQL Server

» Parser, Compiler, Syntaxer, Optimizer, and CLRA

» Storage Engine [SQL Engine]
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TOPIC 2: SAOL SUB LANGURGES

» SQL Server Data Definition Language [DDL]

» SQL Server Data Manipulation Language [DML]

» SQL Server Data Control Language [DCL]

» SQL Server Transaction Dictionary Language [TCL]
» SQL Server Data Retrieval Language [DRL]

TOPIC 3: DML IDATA MANIPULATION LANGURGEI

» Inserting data into table [SELECT, INSERT and SELECT]

» Single Insert and Multiple Inserts

» Modifying table data [UPDATE]

» Removing table data [DELETE]

» BULK INSERT and BCP [Bulk Copy Program]

» MERGE command operation and Incremental Load [SCD and CDC]
» SQL Server Data Types

» Insert table from another table

TOPIC 4: DCL IDATA CONTROL LANGURGE]

» Providing privileges [GRANT]
» Removing privileges [REVOKE AND DENY]

TOPRPIC 5: TCL ITRANSACTION CONTROL LANGURGE]

» Saving work [COMMIT]
» Restore work [ROLLBACK]
» Saving period of work [SAVEPOINT]

TOPIC 6: DRL IDATA RETRIEVAL LANGURGE]I

» Working on SELECT statement
» Working on WHERE, GROUP BY, HAVING, and ORDER BY

» Column and Table Aliases usage

TOPIC "1: ORTA FILTERING CLAUSES

v

=, 1=, <>, >, <, <= =< etc... comparison Operators
AND, OR, NOT Logical operators

b+, -, % /,Mod, Exp etc...Mathematical Operators
» Order By, Top, Where, From and Like

» Group by and Having

» IN, NOT IN, BETWEEN and NOT BETWEEN

» ISNULL and NOT ISNULL

v
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TOPIC 8: MULTI TABLE ODPERATIONS ICOLUMN-WISE]

» Simple Sub Query

» Correlated Sub Query

» Differences between simple and correlated
» Nested Sub Query

» BULK INSERT and BCP [Bulk Copy Program]

TOPIC 9: MULTI TABLE OPERATIONS IROW-WISE SET THEDRY]!

» Set theory generic protocols

» INTERSECT

» UNION

» UNION ALL

» EXCEPT

» Working on incremental loading

TOPIC 18: MULTI TABLE OPERATIONS ICOLUMN WISE-JOINSI

» JOINS real time usage

» CROSS JOIN and CROSS APPLY

» INNER JOIN [EQUI, NON EQUI]

» NATURAL JOIN

» SELF JOIN

» INNER Vs. OUTER JOIN

» LEFT OUTER JOIN

» RIGHT OUTER JOIN

» FULL OUTER JOIN

» Working on ON and WHERE clauses
» MERGE JOIN

» LOOP JOIN

» HASH JOIN

» Unmatched data retrieval

» Incremental load in real time using Joins

TOPIC 11: BUSINESS DATA CONSTRRAINTS AND OATAH RULES

» CHECK, NOT NULL, AND DEFAULT — Domain Integrity

» Primary Key usage and limitations

» Unique Key usage and limitations

» Referential Integrity and FORGINE KEY

» Candidate key and Alternate key

» Normal column and Identity column

» Surrogate key and ldentity column usage

» CASCADING OPTIONS

» ON UPDATE SET NULL, ON UPDATE SET NO ACTION(Default)

» ON DELETE CASCADE, ON UPDATE CASCADE, ON DELETE SET NULL,
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TOPIC 12: INDEXS IBASICS-ADVANCEDI

» Clustered Index Design and Structures
» Nonclustered Index Design and Structures
» Unique Index Design

» Index with Included Columns

» Column storage index

» Working on incremental loading

» Full-Text Index population

» Covering Index Design

» B-Tree and Online Indexes

» Indexed views Vs. Materialized views
» Fill Factor, TEMPDB, Pat_Index

TOPIC 13: SCHEMAS, SYNONYMS, SYSTEM DEFINED VIEWS AND PROCEDURES

» What is Schema? and real time advantages with practical.

» What is Synonym? and real time advantages with practical

» System Defined Procedures usage with examples

» sp_help, sp_helpdb, sp_helptext, sp_rename, sp_recompile, sp_tables
» System Defined Views usage with examples

» sys.tables sysjobactivity, sysssislog

TOPIC 14: DISTINCT, GROUP BY, ROLLUP, AND CUBE

» Differences between GROUP BY and DISTINCT and performance impact
» Differences between GROUP BY and DISTINCT and performance impact
» ROLLUP and CUBE usages

» Generating FULL TOTALS and SUB TOTALS

» Comparing ROLLUP, CUBE and GROUP functions

TOPRIC 15: VIEWS [USER DEFINEDI

» Advantages of Views in SQL

» Tables Vs. Views

» Simple View (Updatable View)

» Complex View (Non-Updatable View)
» Materialized View and real time usage
» Encrypted views Vs. Cascading views
» Limitations of Views
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TOPIC 16: FUNCTIONS [ SYSTEM, USER REFINED & ANALYTICAL ]

» Date Functions - DATEADD, DATE DIFF, DATE PART, FLOOR, CEILING, GETUTCDATE,
, GETDATE, CURRENT_TIMESTAMP, SYSDATETIME, DATE NAME, ISDATE, WEEKDAY,
MONTHNAME, WEEKDAYNAME, SECOND, MINUTE, HOUR, ISDATE

» Other Generic Functions - COALESCE, NULL IF, CURRENT USER, IIF, COALESCE,
NULL IF, CURRENT USER, IIF, SESSIONPROPERT, SYSTEM_USER, USER_NAME, FORMAT,
INSTR, CONCAT

» Cast and Convert Functions

» IF, ELSE, CASE, WHEN & END

» PIVOT & UNPIVOT

» ANALYTICAL FUNCTIONS - ROW_NUMBER () and real time examples, RANK () and real
time examples, DENSE RANK () and OVER () usages, NTILE advantage, PARTITION BY
advantage, Using Group BY along with Analytical Partition

» User Defined Functions Create

» User Defined Functions Calling

» Differences between Function &Procedure

TOPIC 1: STORED PROCEDURES IUSER DEFINEDI

» Use in Real Time and Types

» What is Synonym? and real time advantages with practical
» System Defined Procedures usage with examples

» IN, OUT, INOUT Parameters

» Compare Procedures and Functions

» READONLY Parameters » Using TEMP tables in procedures
» Dynamic Data Insertions with Procedures » Stored Procedure inside Stored Procedure
» Table Variables, Cloning & Data Inserts » Optimizing tips for procedure

TOPIC 18: DIFFERENT TYPES OF TRABLES, VARIABLES, AND CTE

» Local variables vs Global variables with examples
» Local variables Vs. Temp variables and real time usage
» TEMPORARY table usages in real time

» Inline View Vs. Normal View » Multiple examples using CTE
» CTE: Common Table Expressions » ROW_NUMBER () with CTE Queries
» CTE usage in real time » Recursive CTE

TOPIC 18: PROGRAMMING AND ERROR HANDLING INSTRUCTIONS

» IF, IIF, CASE » WHILE, WHEN
» Error Handling in T-SQL » Try, Catch, Throw

TOPIC 28: DYNAMIC SOL IMPLEMENTATION

» Creating Dynamic SELECT statement

» Passing dynamic table names

» Create a procedure with dynamic table names and variables
» Normal SQL Vs. Dynamic SQL
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» What is Python

» What are the popular programming languages

» Why choose python over other programming languages
» How is python perfect for Data Analytics

» Job opportunities after completion of the python course
» Different types of IDEs used for Python programming

» Python Installation

Beginning Python Basics :

» The print statement

» Comments

» Keywords

» Operators

» Variables

» Data types

» Sequences, mutable and immutable objects
» Type casting

» String operations

» Indexing and Slicing

» Simple programs with user input

Conditional statements in Python :

» Indentation

» Simple if statement

» If else statement

» Elif statement

» Nested if condition

» One line if conditions or short hand if conditions

Collections or Data Structures :

» List

» Tuple

» Set

» Dictionary

» Nested collections

» Comprehension programming on Lists and Dictionaries
» Real time examples using Collections
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Functions and Modules :

» Built in functions

» User defined functions

» Function with no arguments and no return value
» Function with arguments but no return value
» Types of arguments

» Local and global variables

» Recursive functions

» Lambda function

» Mapping, filter and reduce

» Built in modules

» User defined modules

Functions and Modules :

» Built in functions

» User defined functions

» Function with no arguments and no return value
» Function with arguments but no return value
» Types of arguments

» Local and global variables

» Recursive functions

» Lambda function

» Mapping, filter and reduce

» Built in modules

» User defined modules

Exception Handling :

» Types of Errors

» User defined functions
» Try, except, finally

» Raise

Regular Expressions :

» Findall

» Tuple

» Split

» Sub

» Regex Functions with meta characters

Text files in Python:

» Open(), read(), write(), close()
» Export data to text files
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Object Oriented Programming :

» Basic concepts of OOP

» Difference between general programming and OOP
» Classes and Objects

» init () method

» Self parameter

» Single inheritance

» Multilevel inheritance

» Multiple inheritance

» Hierarchical inheritance

» Polymorphism

Data Analytics using Pandas Library :

» Data structures in Pandas : Series and DataFrames
» Import and Export data

» Working with Excel, CSV, Json, Delimited data files
» Sorting data (Ascending/Descending)

» Loc[] and iloc|]

» Search and Filter data

» Value_Counts

» Grouping data

» Pivot tables

» Merging data

» Concatenation of data

» Data cleaning

» Remove null values

» Fill null values with mean(), median() and mode()
» ldentify duplicate records

» Remove duplicate records

Data Visualization with Matplotlib library:

» Matplotlib Pyplot

» Matplotlib Plotting

» Matplotlib Markers

» Matplotlib Line

» Matplotlib Labels

» Matplotlib Grid

» Matplotlib Subplot

» Matplotlib Scatter

» Matplotlib Bars

» Matplotlib Histograms
» Matplotlib Pie charts
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Numpy Library (Numerical Python) :

» Creating Arrays
» Array indexing
» Array slicing

» 1D Arrays

» 2D Arrays

» 3D Arrays

» Array join

» Array Search

» Array filter

Database Connectivities :

» Table creation in Oracle

» Oracle database connection in Python

» Collections and documents in NoSQL

» NoSQL database connection in Python

» Creation of Database and Tables in MySQL

» MySQL database connection with Python

» Near real time examples with DB Connections
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