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Data Analytics

e Power Bl ¢ Advanced Excel ¢SQL Server e¢Python

@ Sessions from Industry Experts

@ 90 hrs, Daily 1 hour

6 Daily Class Videos Shared

(4 Rs. 25,000 (Online / Offline)

Multiple Batches Available
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MODULE DURATION FEE WHA YOU'LL LEARN
Power Bl 30 days 9,000 Reports, Dashboards, KPls, Modelling, DAX
Excel 20 days 6,000 Basics to Advanced, Excel Analytics
SQL Server 20 days ¥5,000 Querying databases, Important SQL constructs
Python 20 days ¥5,000 Data handling, pandas, matplotlib, automation
TOTAL 90 days 25,000 W Master Data Analytics ¥
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DATA ANALYTICS TYPES
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Introduction to Excel .

» A description of the interface
» The menu system
» The fundamentals of spreadsheets

Personalizing Excel

» Changing Excel’s Default Options Using AutoCorrect and Customizing It
» Customizing the Ribbon

» Using Functions — Sum, Average, Max, Min, Count....
» Absolute, Mixed, and Relative Referencing

Arithmetic Functions

» Sumlf, Sumlfs Countlf, Countlfs Averagelf, Averagelfs

Text Functions

» Upper, Lower, Proper
» Left, Mid, Right

» Trim, Len, Exact

» Concatenate

» Find, Substitute

Proofing and Formatting

» Formatting Cells with Number formats, Font formats, Alignment, Borders, etc
» Basic conditional formatting

Protecting Excel- Excel Security

» File Level Protection
» Workbook, Worksheet Protection
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Printing Workbooks

» Setting Up Print Area

» Customizing Headers & Footers

» Designing the structure of a template
» Print Titles -Repeat Rows / Columns

Advance Paste Special Techniques

» Paste Formulas, Paste Formats
» Transpose Tables
» Paste Validations

Time and Date Functions

» Today, Now » Day, Month, Year
» Date, Date if, DateAdd » Month, Weekday

New in Excel 2013 / 2016 & 365

» New Charts — Tree map & Waterfall
» Combo Charts — Secondary Axis

» Sunburst, Box, and whisker Charts

» Using Power Map and Power View

» Adding Slicers Tool in Pivot & Tables
» Sparklines -Line, Column & Win/ Loss
» Forecast Sheet

» Smart Lookup and manage Store

» New Controls in Pivot Table — Field, Items, and Sets
» Using 3-D Map

» Auto complete a data range and list
» Various Time Lines in Pivot Table

» Quick Analysis Tool

Filtering and Sorting

» Filtering on Text, Numbers & Colors
» Sorting Options
» Advanced Filters on 15-20 different criteria(s)

Printing Workbooks

» Setting Up Print Area

» Print Titles -Repeat Rows / Columns
» Designing the structure of a template
» Customizing Headers & Footers
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What-If Analysis

» Goal Seek

» Data Tables (PMT Function)
» Solver Tool

» Scenario Analysis

Data Validation

» Number, Date & Time Validation

» Dynamic Dropdown List Creation using Data Validation -— Dependency List
» Custom validations based on a formula for a cell

» Text and List Validation

Logical Analysis

» If Function » Nested If
» Complex if and or functions » How to Fix Errors — iferror

Arrays Functions

» What are the Array Formulas, Use of the Array Formulas?
» Array with if, len, and mid functions formulas.

» Basic Examples of Arrays (Using ctri+shifttenter).

» Advanced Use of formulas with Array.

» Array with Lookup functions

» Vlookup / HLookup » Creating Simple Pivot Tables

» Viookup with Helper Columns » Classic Pivot table

» Creating Smooth User Interface » Basic and Advanced Value Field Setting
» Index and Match » Calculated Field & Calculated Iltems

» Reverse Lookup using Choose Function » Grouping based on numbers and Dates

» Nested VLookup
» Worksheet linking using Indirect

Slicers and Charts

» Using SLICERS, Filter data with Slicers
» Various Charts i.e. Bar Charts / Pie Charts / Line Charts
» Manage Primary and Secondary Axis

Excel Dashboard

» Planning a Dashboard
» Adding Dynamic Contents to Dashboard
» Adding Tables and Charts to Dashboard
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POWER BI

MANDATORY TOPIC 1: POWER Bl DEMO & DATA WAREHOUSE FUNDAMENTALS

@ Power Bl Demo content @ . —

» Data, Data Availability types in IT o | O i Mk sy S|
» IT data storage areas [File stream, Database] o BE— - = % - % =

» Data warehouse, Bl definitions and layers i o

» Power Bl existence in IT, Product services ool () R g e
» Power Bl Tools and Components (00 remie TR Soswer S ss8s

» On-Premise vs. Cloud B et 456 T L )
» OLAP vs. OLTP vs. Insights and Analytics [ Jrovees  @Epowerquey @ oo IOvup]
@ Data warehouse Fundamentals T Inmon Model

» Data warehouse, Data mart and differences
» Types of data marts and real-time usage

» DWH Life Cycles, DWH principles

» DWH Approaches (INMON and KIMBALL)

» Data Granularity, Data movement stages
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MANDATORY TOPIC 2: DATA MODEL THEORY AND PRACTICAL

Dimlourse

@ [Theory and detailed practical with real-scenarios] F«imlﬂl

» Data model, use of data model in Power Bl

» Business, Conceptual, Logical, Physical models

» Dimension, Dimension table & types
(Conformed, Roleplay, Degenerated, Junk, SCD)

» Measures & Types

(fully additive, semi additive, non additive)
» Fact table & Types

( Snapshot, Incremental, Factless fact)
» Schemas (Star, Snow Flake, Galaxy & Hybrid)

» Surrogate key and usages in real time £ :
» 1:1, 1: Many, Many: Many relationships Tl -
» Active, Inactive relationships f o e
» Single and Bi-directional, Cross filter .
» Advanced properties of fields - L
(sort order, date category, aggregators) s ] Snowflake Schema
» Snow Flake schema exmaples

TOPIC 1: INSTALLATION [POWER Bl DESKTOP, GATEWAY, SERVER, REPORT BUILDER & DAX STUDIO]

» Power Bl Cloud / Report Server Desktop installation

» DAX Studio installation, Gateway Installation 1 [_ ﬂ E
» Report Server Installation el "wi

» Paginated Report Builder Installation




VINAY

=4 ¥l

b
dami

25y vinaytechhouse.com

© © +919859 831 831

TOPIC 2: WORKING WITH POWER Bl DESKTOP AND CONNECTING TO MULTIPLE DATA SOURCES

@ [Theory and Complete Practical] RO e b O

» Desktop over view and building blocks of B e e T i |
PBI DESKtOp Common data sources

» Connecting to various sources and T Visualizations »
retrieving data & R ‘*_“__:*"’“*' o
1. Flat, CSV, JSON, Excel files Db ows — 4
2. Databases (SQL Server & Oracle) = Bk E
3. Web i b O M 1 ik e
4. Multiple files load at a time B & M ¥ I—,] ®9 E:?
5. Azure SQL database and DWH i 2 g ?E
6. Analysis Services Models Bk ; ~G on o
(Tabular & ulti-dimensional) . BoD .
7. Python Script D %

8. M-Retrieval

TOPIC 3: WORKING WITH DATABASES, CUBES, MODES & CHANGING MODES

» Working on data modes[very detailed] |
a)lmport b)Direct Query c)Connect Live d) Mixed mode e) Chanding modes Ve T LN

» Differences between Load and Edit options. " B

» Retrive date from related data bases and cube ‘ o L

TOPIC 4: WORKNG ON POWER Bl DESKTOP COMPONENTS

Map

» Power Query, Power Pivot, Power View, Power Map

»

&)

Query

__._|.|_!_\
Lol |
View

TOPIC 5: POWER VIEW MENU TAB OPTIONS-RIBBON OPTIONS & REAL-TIME

File Home Insert Modeling View Optimize Help

f% l"l Faced workbook L:‘ Enter data mimy | Ty
L J
Gat

set = Transborm Refresh
dataw [P SO0 Server X Becont sources + data»

External tools

Ll New visual Igm

BuErhBdAFR oo i
OABOADMBEMEE | B ors i - i

OEASLNE MORSUre Al

Qi |
Fublish  Prep data |

@ File Tab [All options-Detailed Practical] ® View Tab [All options -Detailed Practical]

a)New, Open, Save report

» Report Phone Layout / Desktop View

b)Export Power Bl Template (PBIT), PDF Show Gridlines, Snap Objects to Grid
c)import Power Bl Template, Power Query, Locking Objects on the surface

View, Model, Visual files
d)Options and Settings & About

» Bookmarks creation, viewing, & using in
Dashboard Selection Pane

© Home Tab [All options- Detailed Practicall [Hiding and showing objects]

a)External Data:

» Slicer and Sync Slicers explanation with
practical Performance analyzer test run

Get Data, Recent Sources, Enter Data  » Scale to fit: Page view, Mobile: Mobile
b) Transform data & edit parameters layout, Page options

c) Publishing to cloud service
d) Prop data Al (2025)
e) Quick sources f) Sensitivity

» Show panes: Filters, Bookmarks, Selection,
Performance Analyzer, Sync slicers
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@ Insert Tab [All options - Detailed Practical]

» Visuals: New Page, New Visual, More Visuals
b Al Visuals: Key Influencers, Decomposition
Tree, Smart Narrative, Q & A

b Elements: Text box, Buttons, Shapes, Image

» Power Platform: Paginated Report,
Power Apps, Power Automate

» Sparklines: Add a Sparkline

@ Format Tab [All options-Detailed Practical]

a)Edit interactions for the visual for
cross highlighting, cross filtering, and
none options.

b) Bring forward, send backward etc..
visual option (Z-Order)

® Data / Drill Tab [an options-Detailed Practicall
a) Drill down report creation
b) Drill one level down, multiple levels, &

data drill
c) Visual table, Data point table

TOPIC 6: POWER Bl DATASET PROPERTIES

® Modeling Tab [All options-Detailed Practical]

a)Relationships: Manage Relationsips

b) Create roles and implement row-level
security & dynamic row-level security

Page Refresh: Change detection

Parameters: New parameter

Security: Manage roles, View as

Calculations: New measure, Quick measure,

New column, New table

Q & A: Language, Lunguistic Schema

® HELP Tab [All options-Detailed Practicall

a) Guided learning, documentation,
training videos, blogs, communities,
Power Bl for developers, support and
consulting services

@ External tools tab
DAX studio

@ Optimize tab (2024)
Refresh, Pause, Preset, Optimization

» Create hierarchies and analyzing data

» Create Groups (List, Bin)

» Hide / Unhide columns usage in real-time

» Consider table as Date Table

» Expand and collapse columns

» Incremental refresh & manage aggregations

(] I8! grp_bin count_DiscountValue ~ 0 ug Date Hierarchy
" i8] grp_bin size_Actual_Fee U Year
; CIME Quarter
(] {8: grp_CourselD O Month
(] @i grp_list_Actual_Fee I oy

TOPIC 7: POWER QUERY PROPERTIES [ 8 types of properties and M-Language ]

@ Queries properties [All options —Detailed Practical]

a) Practical on duplicates & references
b) Create groups to classify tables

c) Refreshing table data, Creating reusable functions

@ Query Properties

a) Data transformations by adding, removing

& retaining columns, duplicates, error
b) Working on reusable functions
c) Merging & Joining multiple queries

Copy
Paste

Delete

Rename

Enable load

Include in report refresh

Duplicate

Reference
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: 52 Copy Entire Table
@ CO'UI’I‘II"I propeftles T  Use First Row as Headers

Fd  Add Custom Column

Data types, types of transforms
- Numeric, text, date tranforms

@ Filter properties I

Keep Botom Rows

- Numeric, text & date tranforms

Copy

7 FRemove

@ Parameters properties T
- -
Working on Any, List & Query parameters w
Working on multiple & cascading parameters Ghange pe
lu; Replace Values:
® Miscellaneous Transformations -
owercase
Transpose rows, reverse rows, Pivot & Unpivot UPPERCASE
Quality Transforms [profiling, quality, distribution] Capitalize Each Word
Trim
@ Mash up (M) language Clean
. . Length
Syntax, protocols, variables & conventions ]Soi
Let, In, semicolon, and other functions Sk

Keep Range of Rows..
Keep Duplicates
Keep Ermors

I Remove Top Rows..
Remove Bottom Rows..
Remove Alternate Rows.
Remowve Duplicates
Remove Emmors
Merge Queries.

Append Cueries.

Raplace Errors.
Spiit Column
Group By..
Fill

5 Unpivot Columns

Unpivet Other Columns

=1 Rename.,
Move
Drill Down
Add a5 New Quary

[Round
Absolute Value
Factorial
Base-10 Logarithm
Natural Logarithm
Power
Square Root

| Text Transforms

TOPIC 8: POWER Bl VIEWS, FILTERS, VISUALS AND VISUAL FORMATING OPTIONS

@ Types of views in PBl Desktop
a) Report b) Data c) Relationship d) DAX Query

Build visual
@ Worki ith diff tli I of filt —
OI'- Ing.Wl - iTreren evel o IHTers ﬁ & @
a) Visualization b) Page c) Report
© Data Display Visuals i g E E E g
Card, Multi-row, Table, Matrix, New -card (2024) e S B
@ Simple KPI visuals QBPY~ =
KPI, Gauge, Bullet Chart B3 B8 R Py
o Ui E-800 T
@M t |
ore categories visuals 03 ® 3 -

Charts

Rounded charts : Pie, donut

Bar: Stacked, Clustered, 100% Stacked

Trend: Line, Area, Stacked Area, Ribbon, Mixed, Treemap,
Funnel, Scatter, Waterfall

Maps (Bubble, Filled, Shape, ARCGis, Azure map 2024)

Al Visuals: Key-influencer, De-composition, Smart Narrative, QA

Others: Sparklines, Metric, Paginated Report, R, Python

(] ;Report view

© Custom Visuals

a) Bullet Chart b) Chiclet Slicer c) Hierarchy Slicer :
d) Gantt Chart e) Histogram Chart f) Dual KPI g) Scroller

>
5t
'

i Table view -

Relationship view

{ DAX Query view
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® Non field visuals

a) Image b) Textbox c) Shapes d) Button actions v O Data
Actions: Bookmark, page navigation, back , QA, : dE Build
. . Filters|  Pane .
URL, apply slicers & clear slicers
manager v @ Format
@ Visual Interactions =
a ;
a) Slicers: types, usages, sync slicer [ Bokmars i ke |
b) Filers & types R Selection
c) Edit Interactions :
d) Parameters & What-if parameters [ Pefomanceandlze

TOPIC 9: POWER Bl CLOUD SERVICE (app.powerbi.com)

@ WEB PORTAL NAVIGATIONS

1) Navigation pane, Portal URL Es Coodatermon Vel
2) App Launcher, Settings, Help & Support e
3) Feedback, Account Information .

@ WORKSPACES ——

» My workspace and properties -

» User app workspaces and properties
» Workspace Settings and Roles

» Workspace Access

)

T
1

©@DASH BOARD TEMPLATE

» Create dashboards e

» Add the below tiles B e
Image, Textboc, Video, Streaming, =
Live page, Visual, Bookmark, Workbook,
Insight, Usage metrics

» Share and Subscribe dash board L

» Refresh Dashboard - —

» Manage Alerts '

© APP WORKSPACES (or) CONTENT PACK » [OE] |
» Create, modify, and delete appspace — — :

» Add content (show or hide) D e (P

» Audience (organization or users) - o
» Additional Settings (copy, build)

» Publish and Update app

» Browse App in Web, Desktop and Mobile
» END USER EXPERIENCE PROVIDED

@ Report Server (On-Premise) operations
» Report Server Desktop and
Report Server install and practice.
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TOPIC 10: DAX - The below are the DAX categories, a few important functions covered for 6-7 hours

@ DAX Language General Topics & Advanced @FILTER FUNCTIONS

» Syntax and usage
» Naming conventions, parameters
» Operators, functions (15 categories)

» Addmissingitems, Filter, Filters,Distinct,
Values, Countrows, All, Allexcept, Earlier,
Earliest, KeepFilters, Remove filters,

» Context transition (row, column, filter, multi-row) Calculate, Calculatetable, AllSelected,

» DAX Queries, DAX Studio and SSMS
» DAX FAQS, Optimization & Standards

@ DAX Functions [Very Detailed Practice]

» Good material provided for all the functions
a) Date b) Filter c) Math & Trig d) Statistical

e) Table Manipulated f) Informational

g) Relationship h) Logical i) Parent Child
j) Time Intelligence j) INFO Function

h) Windows Functions (2022 Dec)

i) NEW Functions (2024)

Statements: Evaluate, Define, Var, Order By

@DATE FUNCTIONS
» Calendar, Calendarauto, Day, Month, Year

YearFrac, Date, Time, DateValue, TimeValue,

Edate, EOMonth, Weekday, WeekOfMonth
Today, UTCToday, Now, UTCNow, DateDiff

® TIME INTELLIGENCE FUNCTIONS

» DatesBetween, DatesInPeriod,
ClosingBalanceofmonth, Quarter, Year
OpeningBalanceOfMonth, Quater, Year
Datesytd, Datesqtd, Datesmtd, Totalqtd,
Totalmtd, Totalytd ,FirstDate, LastDate,
FirstNonBlankDate, Lastnonblankdate,

NextDay, NextMonth, NextYuarter, NextYear,

ParallelPeriod, SamePeriodLastYear,
PreviousDay, PreviousMonth, Quarter, Year
StartOfMonth, Quarter Year

@ LOGICAL FUNCTIONS

» And, Or, Not, Iferror, If, Switch, In,
True , False, Coalesce

©@PARENT & CHILD FUNCTIONS

» Path, Pathlength, Pathcontains,
Pathreverse, Pathltem

@ INFO FUNCTIONS
» INFO- View.Measures, View.Columns, View.Tables

®@ WINDOWS FUNCTIONS (2022)
» Index, Offset, Partition, Window

AllINoBlankRow
@ RELATIONSHIP FUNCTIONS

» Related, Relatedtable, UseRelationship,
Crossfilter, ContainsStringExact

@ INFORMATION FUNCTIONS

» ContainsRow, Contains, ContainsString,
Iseven, Isodd, Istext, UserName,
UserPricipalName, LookUpValue, IsError,
IsNonText, IsNumber, IsLogical, Isinscope,
Isonorafter,Hasonefilter, IsCrossFiltered

© AGGREGATE FUNCTIONS

» Sum, Sumx, Average, AverageX, AverageA,
Max,MaxX,MaxA, Min, Minx,MinA,Count,
CountX, CountA, CountBlank, DistantCount,
DistantCountNoBlank, Product, ProductX,
Courtrows, Approximate, Distinctcount

® MATH AND TRIG FUNCTIONS

» Round, MRound, Roundup, Rounddown, Rand,
RandBetween, Sqrt, Trunc, In, Ceiling, Floor,
Gced, Lcd, Exp, Fact, Even, Odd, ABS, Convert,
Currency, Sign

@ STATISTICAL FUNCTIONS

» Permut, Rank.eq, Rankx, Sampl,
Statistical data, Operation functions
MORE DA STATICAL FUNCTIONS COVERED

© TABLE MANIPULATION FUNCTIONS

» AddColumns, AddMissingltems, CrossJoin,
CurrentGroup, DataTable, DetailRows,
DistinctColumn, DistinctTable, Except, Filters,
Generate, GenerateSeries, Groupby,
DataTable, Except, Intersect, Union,
Symmarize, Summarizecolumn,
GenerateSeries, NaturallnnerJoin,
NaturalLeftOuterJoin, Crossjoin, Treatas,
Isempty, Row SelectColumns, Values,

@TEXTUAL FUNCTIONS

» Blank, Code,Unichar,Concatenate,
Combinevalues, Cacatinatex, Trim, Rept,
Replace, Substitute, Find, Search, Format,
Mid, Left, Right, Value, Upper, Lower

@ NEW FUNCTIONS (2024)
b First, Last, Previous, Next, Rank,
Rownumber, Lineast, Match
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MANDRTORY Topic :: DATA, DATABASE AND DATAWAREHOUSE FUNDAMENTAL

® Data and Database Fundamentals

» Data, Data Availability types in IT

» Database, Data Warehouse, and RDBMS

» Data storage areas [structured, semi and unstructured

» RDBMS real-time projects and areas

» Components of RDBMS

» Normalized and de-normalized databases
[Bl and non-Bl]

» SQL Versus T-SQL [MS SQL]

» Other popular database in IT [ORACLE
and TERADATA] and differences

» SQL Server Job Market and Opportunities

» Power Bl History, releases and blogs

® Data warehouse Fundamentals

» Data warehouse, Data Mart and differences
» Types of data marts and real-time usage

» ODS, Stage, EDW, and DW definitions

» Data Lake and Blob Storages

» DWH Life Cycles

» Data Granularity, Data movement stages

TOPIC 1: INSTALLATION ISAOL Server Instance, Editions, Databases, and Tablesl

» Installing SQL Server Instance and multiple Instances

» SSMS Installation, Azure Data Studio, SQL Developer and Operations Studio

» SQL Server Service Starting

» Server name or Instance name & authentication

» Versions and Editions in SQL Server

» Connections [Local and Remote]

» Editions of SQL Server - Enterprise Edition, Standard Edition, Developer Edition,
Work Group Edition, Express Edition

TOPIC 2: DRATABASES AND TABLES

» System Defined Databases & usages - Master, MSDB, TEMPDB and others real-time usage
» User defined databases and usages

» Database creation GUl and Code [MDF & LDF files]

» Differences between command and query

» Query and command execution in SQL Server

» Parser, Compiler, Syntaxer, Optimizer, and CLRA

» Storage Engine [SQL Engine]
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TOPIC 2: SAL SuUB LANGURGES

» SQL Server Data Definition Language [DDL]

» SQL Server Data Manipulation Language [DML]

» SQL Server Data Control Language [DCL]

» SQL Server Transaction Dictionary Language [TCL]
» SQL Server Data Retrieval Language [DRL]

TOPIC 3: DML IDATAR MANIPULATION LANGURGEI

» Inserting data into table [SELECT, INSERT and SELECT]

» Single Insert and Multiple Inserts

» Modifying table data [UPDATE]

» Removing table data [DELETE]

» BULK INSERT and BCP [Bulk Copy Program]

» MERGE command operation and Incremental Load [SCD and CDC]
» SQL Server Data Types

» Insert table from another table

TOPIC 4: DCL IDATA CONTROL LANGURGE]

» Providing privileges [GRANT]
» Removing privileges [REVOKE AND DENY]

TOPRPIC 5: TCL ITRANSACTION CONTROL LANGURGEI

» Saving work [COMMIT]
» Restore work [ROLLBACK]
» Saving period of work [SAVEPOINT]

TOPIC 6: DRL IDATA RETRIEVAL LANGURGE]I

» Working on SELECT statement
» Working on WHERE, GROUP BY, HAVING, and ORDER BY
» Column and Table Aliases usage

TOPRIC "1: ORTA FILTERING CLRAUSES

b=, 1= <>, 5 < <= =< etc.. comparison Operators
» AND, OR, NOT Logical operators

»+,-,* /,Mod, Exp etc...Mathematical Operators
» Order By, Top, Where, From and Like

» Group by and Having

» IN, NOT IN, BETWEEN and NOT BETWEEN

» ISNULL and NOT ISNULL
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TOPIC B: MULTI TABLE ODPERATIONS ICOLUMN-WISE]

» Simple Sub Query

» Correlated Sub Query

» Differences between simple and correlated
» Nested Sub Query

» BULK INSERT and BCP [Bulk Copy Program]

TOPIC 9: MULTI TABLE OPERATIONS IROW-WISE SET THEDRY]!

» Set theory generic protocols

» INTERSECT

» UNION

» UNION ALL

» EXCEPT

» Working on incremental loading

TOPRIC 18: MULTI TABLE OPERATIONS ICOLUMN WISE-JOINSI

» JOINS real time usage

» CROSS JOIN and CROSS APPLY

» INNER JOIN [EQUI, NON EQUI]

» NATURAL JOIN

» SELF JOIN

» INNER Vs. OUTER JOIN

» LEFT OUTER JOIN

» RIGHT OUTER JOIN

» FULL OUTER JOIN

» Working on ON and WHERE clauses
» MERGE JOIN

» LOOP JOIN

» HASH JOIN

» Unmatched data retrieval

» Incremental load in real time using Joins

TOPIC 11: BUSINESS DATA CONSTRRAINTS AND DATAH RULES

» CHECK, NOT NULL, AND DEFAULT — Domain Integrity

» Primary Key usage and limitations

» Unique Key usage and limitations

» Referential Integrity and FORGINE KEY

» Candidate key and Alternate key

» Normal column and Identity column

» Surrogate key and ldentity column usage

» CASCADING OPTIONS

» ON UPDATE SET NULL, ON UPDATE SET NO ACTION(Default)

» ON DELETE CASCADE, ON UPDATE CASCADE, ON DELETE SET NULL,
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TOPIC 12: INDEXS IBASICS-ADVANCEDI

» Clustered Index Design and Structures
» Nonclustered Index Design and Structures
» Unique Index Design

» Index with Included Columns

» Column storage index

» Working on incremental loading

» Full-Text Index population

» Covering Index Design

» B-Tree and Online Indexes

» Indexed views Vs. Materialized views
» Fill Factor, TEMPDB, Pat_Index

TOPIC 13: SCHEMARS, SYNONYMS, SYSTEM DEFINED VIEWS AND PROCEDURES

» What is Schema? and real time advantages with practical.

» What is Synonym? and real time advantages with practical

» System Defined Procedures usage with examples

» sp_help, sp_helpdb, sp_helptext, sp_rename, sp_recompile, sp_tables
» System Defined Views usage with examples

» sys.tables sysjobactivity, sysssislog

TOPIC 14: OISTINCT, GROUP BY, ROLLUP, AND CUBE

» Differences between GROUP BY and DISTINCT and performance impact
» Differences between GROUP BY and DISTINCT and performance impact
» ROLLUP and CUBE usages

» Generating FULL TOTALS and SUB TOTALS

» Comparing ROLLUP, CUBE and GROUP functions

TOPIC 15: VIEWS [USER DEFINED]

» Advantages of Views in SQL

» Tables Vs. Views

» Simple View (Updatable View)

» Complex View (Non-Updatable View)
» Materialized View and real time usage
» Encrypted views Vs. Cascading views
» Limitations of Views
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TOPIC 16: FUNCTIONS [ SYSTEM, USER REFINED & ANALYTICAL. ]

» Date Functions - DATEADD, DATE DIFF, DATE PART, FLOOR, CEILING, GETUTCDATE,
, GETDATE, CURRENT_TIMESTAMP, SYSDATETIME, DATE NAME, ISDATE, WEEKDAY,
MONTHNAME, WEEKDAYNAME, SECOND, MINUTE, HOUR, ISDATE

» Other Generic Functions - COALESCE, NULL IF, CURRENT USER, IIF, COALESCE,
NULL IF, CURRENT USER, IIF, SESSIONPROPERT, SYSTEM_USER, USER_NAME, FORMAT,
INSTR, CONCAT

» Cast and Convert Functions

» IF, ELSE, CASE, WHEN & END

» PIVOT & UNPIVOT

» ANALYTICAL FUNCTIONS - ROW_NUMBER () and real time examples, RANK () and real
time examples, DENSE RANK () and OVER () usages, NTILE advantage, PARTITION BY
advantage, Using Group BY along with Analytical Partition

» User Defined Functions Create

» User Defined Functions Calling

» Differences between Function &Procedure

TOPIC 1: STORED PROCEDURES IUSER DEFINEDI

» Use in Real Time and Types

» What is Synonym? and real time advantages with practical
» System Defined Procedures usage with examples

» IN, OUT, INOUT Parameters

» Compare Procedures and Functions

» READONLY Parameters » Using TEMP tables in procedures
» Dynamic Data Insertions with Procedures » Stored Procedure inside Stored Procedure
» Table Variables, Cloning & Data Inserts » Optimizing tips for procedure

TOPIC 18: DIFFERENT TYPES OF TABLES, VARIABLES, AND CTE

» Local variables vs Global variables with examples
» Local variables Vs. Temp variables and real time usage
» TEMPORARY table usages in real time

» Inline View Vs. Normal View » Multiple examples using CTE
» CTE: Common Table Expressions » ROW_NUMBER () with CTE Queries
» CTE usage in real time » Recursive CTE

TOPIC 18: PROGRAMMING AND ERROR HANDLING INSTRUCTIONS

» IF, IIF, CASE » WHILE, WHEN
» Error Handling in T-SQL » Try, Catch, Throw

TOPRIC 28@: DYNAMIC SOL IMPLEMENTRARTION

» Creating Dynamic SELECT statement

» Passing dynamic table names

» Create a procedure with dynamic table names and variables
» Normal SQL Vs. Dynamic SQL
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» What is Python

» What are the popular programming languages

» Why choose python over other programming languages
» How is python perfect for Data Analytics

» Job opportunities after completion of the python course
» Different types of IDEs used for Python programming

» Python Installation

Beginning Python Basics :

» The print statement

» Comments

» Keywords

» Operators

» Variables

» Data types

» Sequences, mutable and immutable objects
» Type casting

» String operations

» Indexing and Slicing

» Simple programs with user input

Conditional statements in Python :

» Indentation

» Simple if statement

» If else statement

» Elif statement

» Nested if condition

» One line if conditions or short hand if conditions

Collections or Data Structures :

» List

» Tuple

» Set

» Dictionary

» Nested collections

» Comprehension programming on Lists and Dictionaries
» Real time examples using Collections
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Functions and Modules :

» Built in functions

» User defined functions

» Function with no arguments and no return value
» Function with arguments but no return value
» Types of arguments

» Local and global variables

» Recursive functions

» Lambda function

» Mapping, filter and reduce

» Built in modules

» User defined modules

Functions and Modules :

» Built in functions

» User defined functions

» Function with no arguments and no return value
» Function with arguments but no return value
» Types of arguments

» Local and global variables

» Recursive functions

» Lambda function

» Mapping, filter and reduce

» Built in modules

» User defined modules

Exception Handling :

» Types of Errors

» User defined functions
» Try, except, finally

» Raise

Regular Expressions :

» Findall

» Tuple

» Split

» Sub

» Regex Functions with meta characters

Text files in Python:

» Open(), read(), write(), close()
» Export data to text files
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Object Oriented Programming :

» Basic concepts of OOP

» Difference between general programming and OOP
» Classes and Objects

» init () method

» Self parameter

» Single inheritance

» Multilevel inheritance

» Multiple inheritance

» Hierarchical inheritance

» Polymorphism

Data Analytics using Pandas Library :

» Data structures in Pandas : Series and DataFrames
» Import and Export data

» Working with Excel, CSV, Json, Delimited data files
» Sorting data (Ascending/Descending)

» Loc[] and iloc(]

» Search and Filter data

» Value_Counts

» Grouping data

» Pivot tables

» Merging data

» Concatenation of data

» Data cleaning

» Remove null values

» Fill null values with mean(), median() and mode()
» Identify duplicate records

» Remove duplicate records

Data Visualization with Matplotlib library:

» Matplotlib Pyplot

» Matplotlib Plotting

» Matplotlib Markers

» Matplotlib Line

» Matplotlib Labels

» Matplotlib Grid

» Matplotlib Subplot

» Matplotlib Scatter

» Matplotlib Bars

» Matplotlib Histograms
» Matplotlib Pie charts




JNAi

1 -
%25 vinaytechhouse.com

© +919859 831831

Numpy Library (Numerical Python) :

» Creating Arrays
» Array indexing
» Array slicing

» 1D Arrays

» 2D Arrays

» 3D Arrays

» Array join

» Array Search

» Array filter

Database Connectivities :

» Table creation in Oracle

» Oracle database connection in Python

» Collections and documents in NoSQL

» NoSQL database connection in Python

» Creation of Database and Tables in MySQL

» MySQL database connection with Python

» Near real time examples with DB Connections
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