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SQL Server Training

Objectives: e Real-Time Working eInterview Suitable ¢70% Exam Coverage

[% Trainer: Mr. Sreedhar [8+ years of IT Exp, 5+ in SQL]

@ Duration: 35-40 hours, Daily 1 hour

' Modes: Normal / Fast Track / One on One
O Fee: (Normal track) 5000/-

Available Batches: 8 AM, 9 AM, 10 AM, 11 AM, 5 PM, 6PM

Institute Provides

e In-Depth Theory & practical Material e Daily Live Class Videos Shared
e Complete Practical Oriented Training e Good Interaction with the Trainers
e Mock Interviews e Resume Preparation Sessions

SQL SERVER SCENARIOS

|
SQL Databases

[Cloud & On-premises] T Hr Case Study 1:

Sub Queries, Set Theory, & Joins based

SQL Server Introduction 2 Hrs
SQL & T-SQL elements | 2 Hrs
DDL, DML, DCL, TCL, DRL | 8 Hrs
Joins, Sub Queries & Set | 5 Hrs

Case Study 2:
Views, Procedures, & Functions based

Views, Procedures, & Fun |4 Hrs Case Study 3:
Cursors & Triggers | 3 Hrs CTE, Temporary Tables, &Variables based
Temporary Tables | 2 Hrs

Temporary Variables | 2 Hrs SOL SERVER PROJECTS

Dynamic SQL & Exceptions | 2 Hrs

A) BANKING PROJECT

| with different tables, views, procedure,
RESUME PREP & FAQS | 2 Hrs functions, and queries

Miscellaneous 2 Hrs

Real-time and Real-world examples tailored for better learning



@& www.vinaytechhouse.com

Q +91 957-316-8449

MANDATORY Topic 1: DATA, DATABASE AND DATAWAREHOUSE FUNDAMENTALS

Data and Database Fundamentals
>Data and Data Availability in IT
>Database, Data Warehouse, and RDBMS

»Data storage areas [structured, semi and
unstructured

>RDBMS real-time projects and areas

»Components of RDBMS

>»Normalized and de-normalized
databases

[BI and non-BI]
>SQL Versus T-SQL [MS SQL]
>Other popular database in IT [ORACLE
and TERADATA] and differences

>SQL Server Job Market and
Opportunities

Data warehouse Fundamentals

»Data warehouse, Data Mart & differences
>Types of data marts & real-time usage

> ODS, Stage, EDW, and DW definitions
»>Data Lake and Blob Storages

>DWH Life Cycles

>DWH Approaches (INMON and KIMBALL)
>Data Granularity, Data movement stages

i

Cubes
==§ General
SV B Ledger
Files Data
Warehouse
Kimball Model Inmon Model
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e

MANDATORY Topic 2: DATA MODEL FUNDAMENTALS [E-R MODEL AND DIMENSIONAL MODEL]

-

[Theory and Complete Practical]
>Dimension, Dimension Table & types
> Fact, Fact Table & measures types
>Fact less fact table

Star Schema

time

»>Schemas (Star, Snow Flake, Galaxy & Hybrid) iLi;r;e,kef

»Surrogate key and usages in real time

»Business, Conceptual, Logical, Physical
Data Models

>1:1, 1: Many, Many: Many relationships

> Active, Inactive relationships

»Single and Bidirectional relationships

> Cross filtering relationship

>Role Playing real-time usage

»>Surrogate key live usages with practical

day_of_the_week
month

time_key
quarter —
| year
branch_key
branch :
& location_key
branch_key
branch_name units_sold
branch_type "
dollars_sold |
measures avg.sales |

location_key

location key
stret

city
state/province
country
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TOPIC 1: INSTALLATION [SQL Server Instance]

i >Installing SQL Server Instance and multiple Instances E
i »Installing SQL Server usage client components t
! »SSMS Installation |
| >Azure Data Studio understanding !
! >SQL Developer and Operations Studio |
| >SQL Server Service Starting ;

TOPIC 2: SQL Language understanding

| >What is SQL? |
i >How many areas we can use SQL to communicate with Databases? |
i >SQL usage in OLTP, ETL, Reporting & Analysis Process i
i >Azure Data Studio understanding E
' >SQL Versus T-SQL E
i »Various Tools and Utilities to write SQL !

TOPIC 3: SQL Server Editions, Databases, and Tables

>Server name or Instance name & authentication E
>Versions and Editions in SQL Server |
>Connections [Local and Remote] |
»Editions of SQL Server :
Enterprise Edition |
Standard Edition :
Developer Edition |
Work Group Edition :
Express Edition E
>»SQL Server and SSMS Installation :
>SQL Server Management Studio |
Object Explorer :
Query Editor |
»>System Databases and User Databases :
»>System tables and User tables i

______________________________________________________________________________________________

______________________________________________________________________________________________

»System Defined Databases and usages |
>User defined databases and usages E
>Master, MSDB, TEMPDB and others real-time usage E
>Database creation GUI and Code [MDF & LDF files] :
»>SQL Server Agent usage E
>»Windows Vs. SQL Server Authentication !
_ >System tables and User tables i

I
1
I
1
I
I
I
1
I
1
I
1
I
I
I
I
I
I
I
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TOPIC 5: COMMAND, QUERY, AND SQL SERVER ARCHITECTURE

i > Differences between command and query

i >Query and command execution in SQL Server

i >Parser, Compiler, Syntaxer, Optimizer, and CLR

i >Storage Engine [SQL Engine]

! >Lock, File, Transaction Manager, and Buffer Manager
i >Buffers and Threads

' »Buffers and Threads

e e e i s s A i ' et i st e e s e i G S S e e ) e i M, e o Y B e i e el e i i

>SQL Server Data Definition Language [DDL]

>SQL Server Data Manipulation Language [DML]
>SQL Server Data Control Language [DCL]

>SQL Server Transaction Dictionary Language [TCL]
>SQL Server Data Retrieval Language [DRL]

o
- - - - -

> Creating Table Definitions [CREATE]

> Modifying Table Definitions [ALTER]

>Removing Table Definitions [DROP AND TRUNCATE]
>»TRUNACTE and DROP performance differences
>SQL Server Data Types

>Create table from another table

______________________________________________________________________________________________

-

TOPIC 8: DML [DATA MANIPULATION LANGUAGE]

______________________________________________________________________________________________

>Inserting data into table [SELECT, INSERT and SELECT]

>Single Insert and Multiple Inserts

> Modifying table data [UPDATE]

>»Removing table data [DELETE]

>BULK INSERT and BCP [Bulk Copy Program]

>»MERGE command operation and Incremental Load [SCD and CD(C]
>SQL Server Data Types

>Insert table from another table

_____________________5

TOPIC 9: DCL [DATA CONTROL LANGUAGE]

- ———— -

rl

Providing privileges [GRANT]
Removing privileges [REVOKE AND DENY

______________________________________________________________________________________________

v

-
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TOPIC 10: TCL [TRANSACTION CONTROL LANGUAGE]

»Saving work [COMMIT]
»Restore work [ROLLBACK]
»Saving period of work [SAVEPOINT]

______________________________________________________________________________________________

[ SR ——

TOPIC 11: DRL [DATA RETRIEVAL LANGUAGE]

o

>»Working on SELECT statement
>Working on WHERE, GROUP BY, HAVING, and ORDER BY
>Column and Table Aliases usage

-

-

TOPIC 12: DATA FILTERING CLAUSES

e

>=, 1=, <>, >, <, <=, =< etc... comparison Operators
>AND, OR, NOT Logical operators

>+, -, * /,Mod, Exp etc...Mathematical Operators
>Order By, Top, Where, From and Like

> Group by and Having

>IN, NOT IN, BETWEEN and NOT BETWEEN
>ISNULL and NOT ISNULL

______________________________________________________________________________________________

—————————mmm e ————
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TOPIC 13: MULTI TABLE OPERATIONS [COLUMN-WISE]

\ ‘

e e T

e e e e e e

>Simple Sub Query

>Correlated Sub Query

>Differences between simple and correlated
>Nested Sub Query

>Working on TOP, MAX, and MIN real time queries

’

TOPIC 14: MULTI TABLE OPERATIONS [ROW-WISE SET THEORY]

______________________________________________________________________________________________

>Set theory generic protocols
>INTERSECT

> UNION

> UNION ALL

>EXCEPT

>Working on incremental loading

\
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TOPIC 15: MULTI TABLE OPERATIONS [COLUMN WISE-JOINS]

- -

»JOINS real time usage

> CROSS JOIN and CROSS APPLY
>INNER JOIN [EQUI, NON EQUI]

> NATURAL JOIN

»SELF JOIN

>INNER Vs. OUTER JOIN

>LEFT OUTER JOIN

>RIGHT OUTER JOIN

>FULL OUTER JOIN

>»Working on ON and WHERE clauses
>MERGE JOIN

>LOOP JOIN

>HASH JOIN

»Unmatched data retrieval
>Incremental load in real time using Joins

T ——

[ U S I Sy S S S SR SR ——

______________________________________________________________________________________________

E > CHECK, NOT NULL, AND DEFAULT - Domain Integrity

i >Primary Key usage and limitations

! »Unique Key usage and limitations

i >Referential Integrity and FORGINE KEY

E >Candidate key and Alternate key

i >Normal column and Identity column

i >Surrogate key and Identity column usage

i >CASCADING OPTIONS

E ON DELETE CASCADE, ON UPDATE CASCADE, ON DELETE SET NULL,
i ON UPDATE SET NULL, ON UPDATE SET NO ACTION(Default)

______________________________________________________________________________________________

______________________________________________________________________________________________

>Clustered Index Design and Structures E
>Nonclustered Index Design and Structures |
>Unique Index Design !
>Index with Included Columns E
> Column storage index :
> Full-Text Index population i
> Filtered Index Design :
> Covering Index Design |
>B-Tree and Online Indexes |
>»Indexed views Vs. Materialized views {
> Fill Factor, TEMPDB, Pat_Index i

______________________________________________________________________________________________
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TOPIC 18: SCHEMAS, SYNONYMS, SYSTEM DEFINED VIEWS AND PROCEDURES

______________________________________________________________________________________________

»What is Schema? and real time advantages with practical.
>What is Synonym? and real time advantages with practica
»System Defined Procedures usage with examples
sp_help, sp_helpdb, sp_helptext, sp_rename, sp_recompile, sp_tables
>System Defined Views usage with examples
sys.tables sysjobactivity, sysssislog

TOPIC 19: DISTINCT, GROUP BY, ROLLUP, AND CUBE

______________________________________________________________________________________________

> Differences between GROUP BY and DISTINCT and performance impact |
>»GROUP BY and HAVING usages to identify and eliminate duplicates |
»ROLLUP and CUBE usages i
>Generating FULL TOTALS and SUB TOTALS E
»>Comparing ROLLUP, CUBE and GROUP functions !

»Advantages of Views in SQL

»Tables Vs. Views

>Simple View (Updatable View)
»Complex View (Non-Updatable View)
>Materialized View and real time usage
>Encrypted views Vs. Cascading views
»>Limitations of Views

——————

TOPIC 21: FUNCTIONS [ SYSTEM, USER DEFINED, AND ANALYTICAL]

i »Date and Time Formats and Functions E
| >Scalar - Valued Functions i
| >Table - Valued Functions :
! >String Functions |
i SUBSTRING, REPLICATE, REPLACE E
: REVERSE, CHARINDEX E
i LEFT, RIGHT, LEN E
: DFFERENCE, SOUNDEX |
| STRING_SPLIT "
| >Mathematical Functions E
: ABS, ROUND, LOG :
i FLOOR, CEILING :
| SUM, AVG, MAX, MIN, COUNT E
i SQUARE ROOT, SQUARE :
| SIN, TAN, COS |

i e o e s o e e o e i e e s e e s i S e e S S e e S . i Al e e e s . e s e e e e S e i I s i e e g it s S e s St i W
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» Date Functions
DATEADD, DATE DIFF, DATE PART
FLOOR, CEILING
GETUTCDATE, GETDATE, CURRENT_TIMESTAMP, SYSDATETIME
DATE NAME, ISDATE
WEEKDAY, MONTHNAME, WEEKDAYNAME
SECOND, MINUTE, HOUR, ISDATE

> Other Generic Functions
COALESCE, NULL IF, CURRENT USER, IIF
ISNULL, NULLIF, SESSION_USER
SESSIONPROPERT, SYSTEM_USER, USER_NAME
FORMAT, INSTR, CONCAT

> Cast and Convert Functions
>IF, ELSE, CASE, WHEN & END
>PIVOT & UNPIVOT

> ANALYTICAL FUNCTIONS
ROW_NUMBER () and real time examples
RANK () and real time examples
DENSE RANK () and OVER () usages
NTILE advantage
PARTITION BY advantage
Using Group BY along with
Analytical Partition

»User Defined Functions Create
>User Defined Functions Calling

»Differences between Function &Procedure

7

»>Use in Real Time and Types

>System Defined and User Defined Procedures
>Dynamic SQL Queries in Procedures

>IN, OUT, INOUT Parameters

>Compare Procedures and Functions
>READONLY Parameters

>Dynamic Data Insertions with Procedures
>Table Variables, Cloning & Data Inserts
>Using TEMP tables in procedures

»Stored Procedure inside Stored Procedure
> Optimizing tips for procedure
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TOPIC 23: DIFFERENT TYPES OF TABLES, VARIABLES, AND CTE

- ——————

>Local variables vs Global variables with examples
>Local variables Vs. Temp variables and real time usage
>TEMPORARY table usages in real time

>Inline View Vs. Normal View

>CTE: Common Table Expressions

>CTE usage in real time

>Multiple examples using CTE

>ROW_NUMBER () with CTE Queries

>Recursive CTE

_______________________.._
-

TOPIC 24: TRIGGERS

T -

>Use in Real Time and Types
>SCHEMA BINDING
>Triggers Vs. Procedures
>Types of triggers
DML TRIGGERS, DDL TRIGGERS,FOR TRIGGERS, INSTEAD OF TRIGGERS
Rel-time usage of triggers at events

______________________________________________________________________________________________

[ S ————

TOPIC 25: CURSORS [USER DEFINED]

______________________________________________________________________________________________

>What is cursor and advantages of it.

>Cursor Vs. Stored Procedure

>»Working on different types of cursors

> Types of triggers
Static Cursors, Dynamic Cursors, Global Cursors, Local Cursors,
Forward only Cursors, Scroll Cursors, Keyset Cursors

#

________________‘
™ - - -

TOPIC 26: TRANSACTIONS, CHECKPOINT, AND DTC

T

»What is Transaction? usage of it?

>What is DTC [Distributed Transaction Coordinator]
>»What is Checkpoint? usage of it?

> Transactions Vs. Checkpoint

- S S S S SR S S S S R M M S S S N S S S e S S S S R S e e am e e -

TOPIC 27: PROGRAMMING AND ERROR HANDLING INSTRUCTIONS

e ———

>IF, IIF, CASE >WHILE, WHEN
>Error Handling in T-SQL >Try, Catch, Throw



@& www.vinaytechhouse.com

Q +91 957-316-8449

TOPIC 28: DYNAMIC SQL IMPLEMENTATION

- " T " T -

> Creating Dynamic SELECT statement E
>Passing dynamic table names E
>Create a procedure with dynamic table names and variables :
>Normal SQL Vs. Dynamic SQL |

B e e e e e e e e e e e e e e e e e e e e s

S i B e ey

______________________________________________________________________________________________

Functions Vs. Procedures > Functions returning normal variables
Functions returning tables > Calling inline functions

VOV

>Examples of performance issues in real time

>DTA (DB Engine Tuning Advisor)

»Audit Long Running Queries using DMVs and DMFs

> Activity Monitor Tool and Query Statistics Reports
»Logical I/0, Physical I/0 and Database I/0, Wait Time
»Partition Functions and Partition Schemes - Usage

»>Index Management : Internal, External Fragmentation
>Index Page Count and Index Condition Checks

> ONLINE and RESUME Options

>Fast, Detailed Scans and Stats NoRecompute usages

> Creating Workload Files and Trace Files

>DTA with Query Cache (Procedure Cache) & .SQL File Inputs advantage
> Full Text Search (FTS) Mechanism advantage

>Processor, Disk, Memory, Transactions, Database Counters
>Query Costs : IO, CPU Cost, SubTree Cost, Operator Cost

> Parameter Sniffing and OPTIMIZE Options

»Spooling Mechanism and Spool Types for Query LoadS
>Execution Plan Issues with Parameter Sniffing

»Query Blocking Scenarios and Lock Monitors
>Serializable, Snapshot, Repeatable Read Isolation /li>
>Deadlock Simulation and Deadlock Prevention usage

> Full Text (FT) Indexes: Query Tuning. Filter Daemon Host
»Histograms and Event Handling Options

>»Working with SQL SERVER Profiler

>Using Perfmon Tool and AM Tool

>Implementing Compressions for Read Only Data
>Parameter Sniffing and OPTIMIZE Options

>Implementing environment areas in the real time [DEV, TEST, UAT, and PROD]
>Real time scenarios and many important tips
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