%NAY @ www.vinaytechhouse.com
Techinuse Q +91 957-316-8449

MAKE REAL - TIME PROFESSIONALS

Azure Bl (Azure Data Engineer)

Objectives: s Real-Time Working e Interview Suitable #70% Exam Coverage

C% Trainer: Mr. Pavan [10+ years of IT Exp, 5+ in Azure]
@ Duration: 45-50 hours, Daily 1 hour

e Modes: Normal / Fast Track / One on One

@ Fee: (Normal track) 16,000/-

Available Batches: 7 AM, 8 AM, 9 AM, 6 PM, 7 PM

Institute Provides

e In-Depth Theory & practical Material e Daily Live Class Videos Shared
e Complete Practical Oriented Training e Good Interaction with the Trainers
e Mock Interviews e Resume Preparation Sessions

! .
i Azure Resource Group, Resources & services cgse Study 1:
i Azure Accounts

i S Creations of Azure Resources/Services
! Azure pricing and Report

i Azure Storage account Case Study 2:

i Azure SQL Data Movement / Loading from Various

1 Azure Datalake Analytics Storage System to Different Storages
Azure synapse Data warehouse Accounts in Real-Time

' Azure Polybase

i Azure Virtual Machines M|SBI

SSIS ETL(SQL Server Integration Services) A) Banking Project
SSIS Different Deployment Methods
| Azure data Factory

B) TeleCommunications Project

Microsoft Power BI

i Azure Data Bricks S oracin S —
i Azure Active Directory G =) ‘ _
E Azure Resource Provider ﬁ = — @ T %ﬁ I i
i Azure Live Streaming Analytics o Swagetion | | Aaee ynapae Somens PowerB
i Azure Logic Apps I

| Life & Shift Deployment ' B [

| Github or DevOps P o Facay >

' Azure Migration Assesment Tool A e

I

I
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TOPIC 1: Azure Accounts Subscription

>Free Account E
»Student Account E
>Pay As You Go !
»Creation of Accounts ;

R ——

TOPIC 2: Azure Resource Group, Resources & Services

>How to Create Resources and Resource Groups in Microsoft Azure
>Azure Resource Manager vs. classic deployment
»>Azure to Manage or Delete Resource Group and Resource

I
L}
I
I
I
I
I
I
1

-

TOPIC 3: Azure Pricing and Report

>Azure Subscription Maintenance
»>Planning and Managing Cost
>Azure Support Option

>Azure Service Level Agreement
>Azure Cost Analysis and Restriction
>Azure Cost billing Report

- - - - - - - -

’
]
I
I
I
I
I
I
I
]
I
]
I
)
I
I
|

A. Blob

B. File Shares

C. Table

D. Ques

>Storage Service & Account

>Creating a Storage Account

»Standard & Premium Performance

>Understanding Replication

»Hot, Cold & Archive Access Tiers

>Working with Containers & Blobs

>Types of Blobs: Block Blobs, Append Blobs, Page Blobs
>Blob Metadata

>Soft Delete

>Azure Storage Explorer

>Access Blob Securely

>Access Key

>Account Shared Access Token

»Service Shared Access Token >Storage Service Encryption
>Shared Acess Policy >Azure Key Vault

A ey S M S S G S SR SR R S S R ——
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TOPIC 5: Azure SQL

_______________________________________________________________________________________________

>Azure SQL Topics

>Azure SQL Server

»Azure SQL Data Base

>Azure SQL Managed Instance
»Azure SQL IN Virtual Machine
>Introduction to Azure SQL Database
»Comparing Single Database
>»Manged Instance

»Creating and Using SQL Server
»Azure SQL Database Tools
>Migrating on Premise Database to SQL Azure
»Purchasing Models

>DTU Service Tiers

>vCore Based Model

>Serverless Computer Tier

>Service Tiers
- General Purpose / Standard

- Business Critical / Premium

- Hyperscale
>Deployment of an Aure SQL Database
> Elastic Pools
>What is SQL Elastic Pools

Choosing the Correct Pool Size
>Creating a New Pool
>»Manage Pools
>Monitoring and Tuning Azure SQL Database
>Configure SQL Database Auditing
>Export and Import of Database
>Automated backup
>Point in Time Restore
>Restore Deleted Databases
>Long-Term Backup retention
>Active Geo Replication
>Auto Failover Group

Q +91 957-316-8449

______________________________________________________________________________________________

-

»Azure Data Lake Store
-Azure Data Lake Gen1
-Azure Data Lake Gen2
>Azure Data Lake Analytics
>Introduction to Azure Data lake
>What is Data lake
>What is Azure Data lake

___________________.‘
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E »Data Lake Architecture? >Uploading Sample File E
I >Working with Azure Data lake >Using Azure Portal |
| >Provisioning Azure Data lake »Using Storage Explorer :
i >Explore Data Lake Analytics >Using Azure CLI E

>Explore Data Lake Store

e s i i s s i S . e i Ml R i e s B e A i e S A i s e i, i e WP

TOPIC 7: Azure Data Lake Analytics

o S S SR S B SR S S e S S S S A N S R S R SN e S S S S S N S

> Creation of Azure Data Lake Analytics Using Data Lake Gen
>U-SQL Code Job Submitting

>Working with Sample Data and Scripts

>Use of Analytics Units (AU's)

>Heat Map

>Job Graph

>Running USQL Analytics Query from Azure Data Factory

> Automation USQL Script using Trigger in ADF.

e e
- - - - - - - - - -

7’
.

TOPIC 8: Azure Synapse Data warehouse

>Creating the Synapse DWH DB

>Dedicated SQL pools (formerly SQL DW)

»Managing and Loading the Data in DWH Objects
>Loading the data in DWH using ADF from different source.

______________________________________________________________________________________________

TOPIC 9: Azure Polybase

>Creating Master Key
>Creating Scoped Credential
>Creating External Data Source
>Creating External File Format
>Creating External Table

e
-

S

T T T —

>Creating an Analysis Project Using Visual Studio
>Workspace Database, Server, Direct Query, Backup to Disk
>Installation steps, Error Mechanisms

»Creating a Tabular model and Setting

»Data to the Model

-

~
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> Renaming tables
>filtering columns
>Rename Columns

> Monitoring relationships
> Providing relationships
> Create Hierarchies

> Create Partitions

> Create Perspectives

> Create Roles
> Create KPIs
> Deployment

TOPIC 11: Azure Virtual Machines (VM's)

i ————————

by

>How to create Virtual Machine |
> Managing Directories !
>Accessing the RDP from On-premises ':
> Direct Connecting to Remote Desktop through Public IP !
> Different Operating System Configuration. E
>Managing and Reset the VM Password. :

I

> Introduction about SSIS Tool

>Installation Visual Studio SSDT different version for SSIS ETL

> Creating New Project and Modifying the exciting SSIS ETL Project

> Creating different type of Packages

>Control Flow and its different type of Tasks

> Data Flow Task and its different type of components and Transformation

> Different Source and Destination for data loading

> Full Load development using SSIS Package

>Incremental Process using Lookup Transformation, SCD and CDC components
> Automation or scheduling the exiting SSIS ETL Packages for daily load

>SSIS Package Deployment model using Ispac file and Manifestfiles

>Project Deployment model, Package Deployment and File System model fo SSIS ETL Packages
> Creating Jobs to schedule the exiting SSIS ETL Packages and configurations

TOPIC 13: SSIS Different Deployment Methods

>SSIS Package Deployment model using Ispac, File Syetem and Manifestfiles
> Project Deployment model, Package Deployment and File System model fo SSIS ETL Packages
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TOPIC 14: Azure data Factory ADF ETL

T -

Azure Data Factory vs SSIS

Q +91 957-316-8449

,

>Linked Services

>Data Sets

>Pipelines

>Parameters

>Variables

>Copy Data

>»Monitor Manage

>Autor and Deploy

> Different kinds of integration runtimes
>How to create pipelines from template
>How to configure different Integration Runtimes
>Azure Integration runtime

>Azure Self Hosted Integration Runtime
> SSIS Integration runtime

Move & Transform

> Copy Data
>Data Flow

General Activities

>Execute Pipeline
»Execute SSIS Package
>Get Metadata
>Lookup

>Stored procedure
>Set Variable

>Delete

>Wait

>Until

>WEB

>Precedence Constraints
>Breakpoint

>Data Flow

Iteration & Conditionals

> Filter
»For Each
> If Condition

Integration Runtime

>Azure Integration Services Runtime (Auto Resolved)
»SSIS Integration Services Runtime (Lift & Shift Operation)
>Self-Hosted Integration Runtime (Extract data from external Sources)

-
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>Append Variable !
I
I
I
I
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Data Flow Transformation

>Append Variable
>Source

>Sink

>Filter

>Select
>Conditional Split
»Derived Column
>Join

>Lookup

>Union
>Aggregate

» Exists
>Surrogate key

> Pivot

>Un Pivot

>Sort

>Alter Row

Different Type of Loading Process in ADF |
>Incremental Load using SCD (Insert Update operation) and Lookups Transformation E
>Full Load operation for Dimension and Master data |

>Delta Load Process for Daily load with latest date data
>Regular or Daily Load

ADF ETL Pipeline Deployments:-

>What are ARM Templates and how to Export and Import?

>How to Deploy Data Factory Pipelines DEV, Test, Prod environment

>How to Create a Git Hub Account

>How to work with Repository, Branch, Pull Request, Push Request Merge Code?
>Code Repository in Git Hub for CICD deployments

>Scheduling Automation ADF ETL Pipeline Using

Triggers & Monitor: -

>What is Trigger and its type?

>+ Normal Schedule Trigger

>Event-Based Trigger

> Tumbling Window

>tLogic App to Schedule Mail Alters and ADF Pipeline
>Debugging and Monitoring Pipelines

>Error handling and Logging error records

> Lift and Shift SSIS packages into Azure Data Factory

-
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Case Study | Practice on Azure ADF ETL: -

>Moving data from Blob to Blob

>Moving data from Blob to Azure SQL Server

>Moving data from SQL Server to Blob

»Moving data from ADLS to Azure SQL Server

>Moving data from ADLS to ADLS (Gen1 & Gen2)

>Configure different Types of Integration Runtimes

>Azure Integration runtime

>Azure Self Hosted Integration Runtime

»SSIS Integration runtime for Lift & Shift operation

>Moving Data from Blob to On Premise SQL Server

>Moving Data from On Premise SQL Server To Azure SQL

>Moving Data from On Premise files to Azure SQL Server

>Moving Data from On Premise files to ADLS and to Azure SQL Server

>Load data from Multiple tables into SQL Server using dynamic expressions & schema

>Creation scripts

>Load data from Multiple Files with SQL Server dynamic expressions & schema creation

>Script

>Implementing and auditing logs for developed package to track the detail about
ADF ETL Pipelines.

>Mail Alter configuration in ADF ETL pipeline.

>Stored procedure inputs and outputs parameters configuration to load the data

>Use dynamic parameters within the pipeline

>Trigger a pipeline using another pipeline

> Different ways to deploy Azure resources from one resource group to another
resource group

>Deploy SSIS packages to ADF and Schedule

>Query Azure Data Lake using U-SQL activity and running the same ADF pipeline

>Loading the data into Azure DWH Synapse from multiple sources
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> Configure Databricks

> Creating the Account using Azure and Data Brick Community Edition

> Creating and Configuring Clusters and types.

> Create Notebooks in different platform (Python, Scala, R, Spark SQL
>Working with Notebook & Libraries Options

> Scheduling the Notebook.

>Working with Data Brick File System and Notebooks

> Data Movement\Loading Using Blob, DWH Synapse and other Storages.
>Filler the Data and Modification

> Assign the Cluster based on requirement to the Notebook.

g et e e e e S e e S e
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TOPIC 16: Azure Active Directory

- -

>Role \ User Creation
>Working with App Registration for Access Key
»Permission

| SR ——

i >What is Azure Event Grid Event Hub E

i >How to configure Event and Hub i

E >Perform Realtime analytics on Event Hub Data !

i > Useful of Grids in Azure Data Factory for Storage Triggers E
TOPIC 18: Azure Live Streaming Analytics

i > Data Loading Process and Data Movement E
TOPIC 19: Azure Logic Apps

i > Configuring and Sending Mail Alerts Using Templets E

i >Scheduling the Resource or ADF using it. E

TOPIC 20: GitHub or DevOps

______________________________________________________________________________________________

~

> Creating the Account

»Managing the Master and Main Brach

> Creation of Local Branch and code merging
> Working with Merging and Pull Request
>Deployment and Code Merging.

| S S ———

e e i e e o s o W i e e s e o A e S s o M i A e i i A B e e e s e e e Nt iy e s e s e i il

TOPIC 21: Azure Migration

o ————

rl

>Migration On-Premises data to Azure cloud
»>Working on BACKUP and DACPACK file to move data to Azure Storages
> Data Migration using Azure Migration Assessment Tool

'
I
I
I
I
I
L}
I
L}

o

______________________________________________________________________________________________

o,

>»What is Power Bl
>What is Power Bl Service > Publish Reports into power Bl cloud services
>How to create Reports in Power Bl desktop Using Azure Data sources

e e i o e i i e i e i e i e s o s e e e el . o e e S S e e S e’ e Bt e o e g . e e g Bl
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Power BI
| FIRST DEMO |

Taught by

| MR. VINAY J

Get the Best Power Bl Training in
Hyderabad | Free Demo #1

To watch
our Latest Demos

SUBSCRIBE TO OUR YOUTUBE

@ Vinay Tech House

tgo-vv

COURSES WE OFFER

POWER BI

DATA ANALYST/ ANALYTICS
MICROSOFT FABRIC

SQL SERVER

ADE / AZURE BI

ADF: AZURE DATA FACTORY
ADB: AZURE DATA BRICKS
MSBI

POWER APPS

POWER AUTOMATE
INFORMATICA

EXCEL

PYTHON

For Regular Updates on Demos (Free)

Follow us on Instagram / Facebook
@VINAYTECHHOUSE

For more information, Call us on: +91 95731 68449

504, Nilgiri Block, Adithya Enclave, Beside Ameerpet Metro, Hyderabad




